Microsoft Expression Web is creating an unwanted default.html

Running Microsoft Expression Web 4 on a Windows 7 Platform, I recently installed it on a new machine.  When I open a site for editing, an unwanted file is created -- default.html.   Moreover, within the site, every link and reference to index.htm is replaced with default.html     This hasn't occurred with previous installations on other machines, and I'd like to prevent it from happening.

In responding, please focus on fixing the problem with my existing software, rather than suggesting alternative applications for web site creation and management.   Thanks!
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Luke ChungPresidentCommented:
Does the IIS setting for the site (or folder) prioritize default.html over your previous index.htm?
ddantesAuthor Commented:
Thank you for your comment.  I am not familiar with the IIS setting.  How can I check that?
Luke ChungPresidentCommented:
Internet Information Services is what hosts the web site on that machine. It has a variety of configuration options for pages. One of the settings is the prioritization of how pages are served when just the folder name is given.

I'm not that familiar with IIS, but I believe you can copy settings from one machine or web site to another. It'd be better to do that than to set individual settings since there may be other things that are out of sync.

If the problem is at the IIS level, EW has nothing to do with it.
CEOs need to know what they should worry about

Nearly every week during the past few years has featured a headline about the latest data breach, malware attack, ransomware demand, or unrecoverable corporate data loss. Those stories are frequently followed by news that the CEOs at those companies were forced to resign.

ddantesAuthor Commented:
On this notebook computer, there is no Internet Services Manager option in Control Panel>Administrative Tools.  I assume IIS is not installed on this system.
RobOwner (Aidellio)Commented:
It us still possible that it's installed but the management tools are not.

Go to Control Panel-> Programs and Features

Click on Turn Windows features on or off

Scroll down to Internet Information Services and expand it.

You should see what components of it are installed.

Please post a screenshot and we'll be able to tell you if it's installed
ddantesAuthor Commented:
IIS settings screenshot   Thank you.  Here is the screenshot.
RobOwner (Aidellio)Commented:
Ok, I think it's obvious that you don't have it installed.

It does look to be a bug, even in version 4:

Scroll down to "Tools > Page Editor Options > Authoring Tab".  You'll see that it defaults to renaming all index.htm files to default.htm

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ddantesAuthor Commented:
Thank you for that link.  So, has there been an update or fix which can be applied to EW4 to cure that bug?  I found articles mentioning that the bug was not fixed with SP-1 or SP-2, but how about SP-3?
RobOwner (Aidellio)Commented:
Sorry I don't know. What version are you running? If you're running sp3 and it's exhibiting the same behaviour them I'm guessing it hasn't.

I'm installing it now to see of I can reproduce your issue.
RobOwner (Aidellio)Commented:
Microsoft Expression Web 4 Service Pack 2 (SP2)
Released: 7/07/2011
Version: 4.0.1303.0 (found if you expand details)

Microsoft Expression Web 4 (Free Version)
Released: 20/12/2012
Version: 4.0.1460.0 (found if you expand details)

So it looks like it's been re released under a different licensing model. The "free"version would otherwise be SP3.  Have you tried this version?
ddantesAuthor Commented:
Thank you.   I'm running SP-2, and I have downloaded SP-3 but not yet installed it.  I haven't tried the "free version".   However, I can no longer reproduce the problem.  I think I'm working under the same conditions as those which existed when the issue occurred.  In any case, I'm satisfied with your answer, pointing out a known bug.  If the issue re-occurs, I'll try installing SP-3.  Thanks again for your help.
RobOwner (Aidellio)Commented:
No problem, thanks for the points and great to hear you're not having the issue anymore.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development Software

From novice to tech pro — start learning today.