Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium


Linux server not receiving email

Posted on 2014-11-10
Medium Priority
Last Modified: 2014-11-30
I know nothing about Linux but am trying to help someone with a Linux email issue.

When you boot the Linux box you eventually get to a DOS environment looking prompt wanting a username.  I supply admin and then am prompted for the password.  When I enter the password I get a gray box with 8 to 10 options.. "Test for Internet", etc.   I assume that this machine is booting properly.

This machine is also an email server.  From a Windows 7 workstation you can no longer get email.  You can send, but not receive.  If you use Horde for WebMail the inbox is empty.

The domain is ateng.com.

You can pull up /server-manager just fine... run reports (if you know what to run), etc.

Email stopped working Nov 1.

Any thoughts?
Question by:classnet
LVL 20

Expert Comment

by:Peter Hutchison
ID: 40433822
1. Check the logs at /var/log to see if anything has happened over past few days.
2. Sounds like SMTP is working but the POP3 or IMAP4 services have stopped working.
3. Not knowning what Linux distribution you are using or Email service you are using, I cannot give anything further..

Expert Comment

by:Jerry Mills
ID: 40433869
Your Linux server smtp is definitely NOT working from the Public side.  Only active ports are 110, 119.  Domain ateng.com points to MX records showing smtp.ateng.com at IP address:  You also may be restricting smtp access with firewall.

Since you are not familiar with Linux I recommend you reboot the server.  There are no web services showing so you need to find out what critical apps might be running prior to rebooting.  From command line you do a 'shutdown -r' and it will timeout after notifying any users then reboot.  Linux reboots will preen disc and restart all services configured to restart such as SMTP.

Once it is rebooted post a comment and I will retest it.  If no joy you will need to find a Linux expert to work on your problem.   After reboot check you boot.log which generally is at /var/logs.  Also execute dmesg from command line to collect what it says.

Author Comment

ID: 40433880
Thank you Jerry (I had rebooted earlier).  Do you get to the /var/logs from the gray screen that I described?  

You see, after a reboot all that I am left with is a prompt looking for a user name.  Supplying the credentials yields the gray box.

I know that is a good address as I pinged it using the -t parameter (keep pinging) and it died when I unplugged the cord to the server.  Yes... I was pinging it from outside the network.

Thanks again.
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.


Expert Comment

by:Jerry Mills
ID: 40433929
Since I don't know version of Linux or configuration I can't say what you are seeing.  If you were really logging in as administrator typically you get a DOS like screen.  Make sure you have superuser login name and password.

Did find other SMTP port available and imap port

Active TCP ports:    465,587,143,993,110,119

So SMTP is responding on alternative ports 465, 587 and 143 (Imap)

How are you connecting?  Telnet, SSH or Web? (Port 80 is inactive)

Doesn't ping from my location but I can probe it.  That suggest firewall restrictions except for those services permitted through.  

Name:    smtp.ateng.com

> exit


Pinging with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Expert Comment

by:Jerry Mills
ID: 40433955
Sent Test message to bad email address from my mail server and unable to deliver to your mail server.  Test message is waiting in queue on my mail server and is unable to deliver because your SMTP is not responding.

Since can't ping I believe you have firewall rules in place.

Author Comment

ID: 40434113
Jerry... since this happened on Nov 1 and it appears to be a firewall issue and no one, supposedly, did anything, could this be an ISP thing?  Perhaps they changed some rules and no one paid attention to any forewarning?

Expert Comment

by:Jerry Mills
ID: 40434172
Linux has a built - in firewall.  Access to the mail server might be restricted to certain addresses in which case a mail server in the wild (public) can't access your mail server.  That could be result of network changes you are not aware of performed by someone else.

It would definitely not be the ISP.

Try opening a telnet connection from you computer.   CMD is  typically:   telnet 96.x.x.x 587.  You should see a response from the mail server identifying itself.
LVL 19

Expert Comment

by:Gabriel Orozco
ID: 40435333
to be sure, you can post your iptables rules here with
iptables -L -vn

or, to test, you can try to add a rule to accept email from outside:
iptables -I INPUT -p tcp --dport 25 -j ACCEPT

and try from outside again. it is easy to use another linux and telnet to test the port:
telnet <yourip> 25

you can exit with "quit"

Expert Comment

by:Jerry Mills
ID: 40435456
Hi Redimido - Port 25 is not active on classnet's Linux server.  Port 587 is active but not accepting connections telnet.  I have tried from Florida and California yesterday and also same result today.  Can you try: from your location for classnet?

Accepted Solution

classnet earned 0 total points
ID: 40465450
I have given up on this... I am not a Linux person and this is, apparently, beyond my pay grade.

Author Closing Comment

ID: 40472373
I am giving up on this... I'm not a Linux person.

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have written articles previously comparing SARDU and YUMI.  I also included a couple of lines about Easy2boot (easy2boot.com).  I have now been using, and enjoying easy2boot as my sole multiboot utility for some years and realize that it deserves …
Among the most obnoxious of Exchange errors is error 1216 – Attached Database Mismatch error of the Jet Database Engine. When faced with this error, users may have to suffer from mailbox inaccessibility and in worst situations, permanent data loss.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Suggested Courses
Course of the Month14 days, 22 hours left to enroll

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question