Oracle 11g startup issue after Linux VM restore

Guest OS Oracle Linux 4/5/6(64-bit).
I restored the VM with a commercial backup/restore agent but unable to startup the database. Please see error message below.

SQL> select status from v$instance;
select status from v$instance
ERROR at line 1:
ORA-01034: ORACLE not available
Process ID: 0
Session ID: 0 Serial number: 0

SQL> startup
ORA-01078: failure in processing system parameters
ORA-01565: error in identifying file '+DATA/MySID/spfileMySID.ora'
ORA-17503: ksfdopn: 2 Failed to open file +DATA/MySID/spfileMySID.ora
ORA-29701: unable to connect to cluster synchronization service
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Is your ASM instance started?
Is your clusterware started?
mrongAuthor Commented:
The listener must be started before starting the database,right?
yes, but your errors aren't listener errors, they are cluster and asm errors
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

mrongAuthor Commented:
tried lsnrctl status
got connecting to (ADDRESS=(PROTOCOL=tcp) (HOST=)(PORT=1521)
TNS-12541: TNS: no listener
TNS-12560: TNS: protocol adapter error
TNS-00511: No listener
Linux Error: 111: Connection refused

In the tnsnames.ora and listener.ora the HOST are set to the host name.
lsnrctl start

but your previous errors point to other issues
mrongAuthor Commented:
How to reset ASM?
You cannot reset anything. You need to restore Oracle from RMAN backup. Storage cloning/backups could only work with completely shut down oracle DB provided they properly include all oracle data and temporary files of same moment.
mrongAuthor Commented:
There is no data imported in my database. Now my problem is to start ASM instance.
Maybe I need to rebuild the database?

>>> ORA-29701: unable to connect to cluster synchronization service

Has this been addressed yet?

crsctl check cluster -all
mrongAuthor Commented:
I tried the following
[oracle@db01 ~] $ crsctl check cluster
bash: crsctl: command not found
set your path to include your grid control home's bin directory

if your cluster ware was installed with role separated management you will need to login or su to the grid owner

also, include the "-all"

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mrongAuthor Commented:
From linux->Application->System Tools->Disk Utility, I can see DATA1,DATA2, FRA1 are not mounted.
Can I mount it back?
you tell us,  can you?

my guess is no because your clusterware isn't running.  Or if it is, we don't know because we don't have any status info on it.
mrongAuthor Commented:
how to set my path to include the grid control home's bin directory?
I think you should bring your system admin and dba in to help you navigate through your system setup.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.