Solved

connecting to filezilla FTP site via internet explorer

Posted on 2014-11-11
27
547 Views
Last Modified: 2014-11-25
hello

we have a single Microsoft sbs2012 server and I have setup a small FTP area using filezilla,

we can connect to this just fine using the filezilla client but we need to be able to connect to this just using internet explorer.

can anyone advise whether this can be done, and if so, what we need to dotoslloe this, as at the moment it does not work in this way.

any advice much appreciated.

many thanks
0
Comment
Question by:nigelbeatson
  • 18
  • 9
27 Comments
 

Author Comment

by:nigelbeatson
ID: 40434671
sorry - sbs2011 - typo
0
 
LVL 35

Expert Comment

by:Kimputer
ID: 40434813
FTP is very standard, and IE supports FTP too (though why use a web browser for FTP work, when there are perfectly capable clients available, as you've seen already where it works flawlessly in Filezilla client).
What are your procedures when using IE?
Normal way: use address bar or favorites in IE with this address:

ftp://username:password@ftp.server.ip.or.hostname
0
 

Author Comment

by:nigelbeatson
ID: 40434934
this is an area we share for one of our clients to access. they have requested direct access via internet explorer so they don't have to have the filezilla client installed for anyone who may need to access it.

personally, I would use the FTP client, but as they are our valued client and have requested this, I was hoping to be able to provide it for them.

I tried the format you suggested but I cannot get it to work.

many thanks
0
 
LVL 35

Expert Comment

by:Kimputer
ID: 40435036
Try only ftp://ftp_server_IP or  ftp://ftp_hostname
See if you at least get a username/password prompt, otherwise something else is wrong.
0
 

Author Comment

by:nigelbeatson
ID: 40435051
yes when. use the shortened version I get the login box appear, but the login fails.

ie shows cannot display the webpage.

when I look at the sever admin the last thing it shows is - 421 could not create socket.

so the connection is hitting the server but it still fails.

any suggestions?

many thanks
0
 

Author Comment

by:nigelbeatson
ID: 40435117
Here is the full log when I try to connect using ftp://host

We then get the login box, and eventually ie declares that it could not display the page.

 (007801)11/11/2014 15:13:33 - (not logged in) (86.135.201.131)> Connected, sending welcome message...
(007801)11/11/2014 15:13:33 - (not logged in) (86.135.201.131)> 220-FileZilla Server version 0.9.41 beta
(007801)11/11/2014 15:13:33 - (not logged in) (86.135.201.131)> 220-written by Tim Kosse (Tim.Kosse@gmx.de)
(007801)11/11/2014 15:13:33 - (not logged in) (86.135.201.131)> 220 Please visit http://sourceforge.net/projects/filezilla/
(007801)11/11/2014 15:13:39 - (not logged in) (86.135.201.131)> USER anonymous
(007801)11/11/2014 15:13:39 - (not logged in) (86.135.201.131)> 331 Password required for anonymous
(007801)11/11/2014 15:13:45 - (not logged in) (86.135.201.131)> PASS *****
(007801)11/11/2014 15:13:45 - (not logged in) (86.135.201.131)> 530 Login or password incorrect!
(007801)11/11/2014 15:13:45 - (not logged in) (86.135.201.131)> disconnected.
(007802)11/11/2014 15:14:05 - (not logged in) (86.135.201.131)> Connected, sending welcome message...
(007802)11/11/2014 15:14:05 - (not logged in) (86.135.201.131)> 220-FileZilla Server version 0.9.41 beta
(007802)11/11/2014 15:14:05 - (not logged in) (86.135.201.131)> 220-written by Tim Kosse (Tim.Kosse@gmx.de)
(007802)11/11/2014 15:14:05 - (not logged in) (86.135.201.131)> 220 Please visit http://sourceforge.net/projects/filezilla/
(007802)11/11/2014 15:14:11 - (not logged in) (86.135.201.131)> USER hdechem
(007802)11/11/2014 15:14:11 - (not logged in) (86.135.201.131)> 331 Password required for hdechem
(007802)11/11/2014 15:14:17 - (not logged in) (86.135.201.131)> PASS ******
(007802)11/11/2014 15:14:17 - hdechem (86.135.201.131)> 230 Logged on
(007802)11/11/2014 15:14:25 - hdechem (86.135.201.131)> CWD /
(007802)11/11/2014 15:14:25 - hdechem (86.135.201.131)> 250 CWD successful. "/" is current directory.
(007802)11/11/2014 15:14:25 - hdechem (86.135.201.131)> TYPE A
(007802)11/11/2014 15:14:25 - hdechem (86.135.201.131)> 200 Type set to A
(007802)11/11/2014 15:14:25 - hdechem (86.135.201.131)> PASV
(007802)11/11/2014 15:14:25 - hdechem (86.135.201.131)> 421 Could not create socket.
(007802)11/11/2014 15:14:25 - hdechem (86.135.201.131)> disconnected.
(007803)11/11/2014 15:14:25 - (not logged in) (86.135.201.131)> Connected, sending welcome message...
(007803)11/11/2014 15:14:25 - (not logged in) (86.135.201.131)> 220-FileZilla Server version 0.9.41 beta
(007803)11/11/2014 15:14:25 - (not logged in) (86.135.201.131)> 220-written by Tim Kosse (Tim.Kosse@gmx.de)
(007803)11/11/2014 15:14:25 - (not logged in) (86.135.201.131)> 220 Please visit http://sourceforge.net/projects/filezilla/
(007803)11/11/2014 15:14:31 - (not logged in) (86.135.201.131)> USER hdechem
(007803)11/11/2014 15:14:31 - (not logged in) (86.135.201.131)> 331 Password required for hdechem
(007803)11/11/2014 15:14:37 - (not logged in) (86.135.201.131)> PASS ******
(007803)11/11/2014 15:14:37 - hdechem (86.135.201.131)> 230 Logged on
(007803)11/11/2014 15:14:45 - hdechem (86.135.201.131)> CWD /
(007803)11/11/2014 15:14:45 - hdechem (86.135.201.131)> 250 CWD successful. "/" is current directory.
(007803)11/11/2014 15:14:45 - hdechem (86.135.201.131)> TYPE A
(007803)11/11/2014 15:14:45 - hdechem (86.135.201.131)> 200 Type set to A
(007803)11/11/2014 15:14:45 - hdechem (86.135.201.131)> PASV
(007803)11/11/2014 15:14:45 - hdechem (86.135.201.131)> 421 Could not create socket.
(007803)11/11/2014 15:14:45 - hdechem (86.135.201.131)> disconnected.
(007804)11/11/2014 15:14:46 - (not logged in) (86.135.201.131)> Connected, sending welcome message...
(007804)11/11/2014 15:14:46 - (not logged in) (86.135.201.131)> 220-FileZilla Server version 0.9.41 beta
(007804)11/11/2014 15:14:46 - (not logged in) (86.135.201.131)> 220-written by Tim Kosse (Tim.Kosse@gmx.de)
(007804)11/11/2014 15:14:46 - (not logged in) (86.135.201.131)> 220 Please visit http://sourceforge.net/projects/filezilla/
(007804)11/11/2014 15:14:52 - (not logged in) (86.135.201.131)> USER hdechem
(007804)11/11/2014 15:14:52 - (not logged in) (86.135.201.131)> 331 Password required for hdechem
(007804)11/11/2014 15:14:58 - (not logged in) (86.135.201.131)> PASS ******
(007804)11/11/2014 15:14:58 - hdechem (86.135.201.131)> 230 Logged on
(007804)11/11/2014 15:15:06 - hdechem (86.135.201.131)> CWD /
(007804)11/11/2014 15:15:06 - hdechem (86.135.201.131)> 250 CWD successful. "/" is current directory.
(007804)11/11/2014 15:15:06 - hdechem (86.135.201.131)> TYPE A
(007804)11/11/2014 15:15:06 - hdechem (86.135.201.131)> 200 Type set to A
(007804)11/11/2014 15:15:06 - hdechem (86.135.201.131)> PASV
(007804)11/11/2014 15:15:06 - hdechem (86.135.201.131)> 421 Could not create socket.
(007804)11/11/2014 15:17:06 - hdechem (86.135.201.131)> 421 Connection timed out.
(007804)11/11/2014 15:17:06 - hdechem (86.135.201.131)> disconnected.


And her is the log from when we get a succesful connection when using the Filezilla client :-

(007805)11/11/2014 15:18:42 - (not logged in) (86.135.201.131)> Connected, sending welcome message...
(007805)11/11/2014 15:18:42 - (not logged in) (86.135.201.131)> 220-FileZilla Server version 0.9.41 beta
(007805)11/11/2014 15:18:42 - (not logged in) (86.135.201.131)> 220-written by Tim Kosse (Tim.Kosse@gmx.de)
(007805)11/11/2014 15:18:42 - (not logged in) (86.135.201.131)> 220 Please visit http://sourceforge.net/projects/filezilla/
(007805)11/11/2014 15:18:48 - (not logged in) (86.135.201.131)> USER hdechem
(007805)11/11/2014 15:18:48 - (not logged in) (86.135.201.131)> 331 Password required for hdechem
(007805)11/11/2014 15:18:54 - (not logged in) (86.135.201.131)> PASS ******
(007805)11/11/2014 15:18:54 - hdechem (86.135.201.131)> 230 Logged on
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> SYST
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> 215 UNIX emulated by FileZilla
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> FEAT
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> 211-Features:
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)>  MDTM
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)>  REST STREAM
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)>  SIZE
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)>  MLST type*;size*;modify*;
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)>  MLSD
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)>  UTF8
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)>  CLNT
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)>  MFMT
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> 211 End
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> PWD
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> 257 "/" is current directory.
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> TYPE I
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> 200 Type set to I
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> PASV
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> 421 Could not create socket.
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> PORT 86,135,201,131,223,165
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> 200 Port command successful
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> MLSD
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> 150 Opening data channel for directory list.
(007805)11/11/2014 15:19:02 - hdechem (86.135.201.131)> 226 Transfer OK

Both seem to declare "421 could not create socket" but the filezilla connaction lets me see our shared folders etc and allows me to upload and download data.

Any ideas?

Many thanks
0
 
LVL 35

Expert Comment

by:Kimputer
ID: 40435124
You should set a passive port range in Filezilla server > Settings > Passive mode settings
tick: Use Custom port range 21000 - 21100
Default J(selected)
Don't use ext ip (ticked)
Now on your modem/router/firewall, add this port range (21000 through 21100) to forward to the server.
0
 

Author Comment

by:nigelbeatson
ID: 40437037
We have made the changes to the filezilla server and redirected ports to the local IP address of our server. We have only opened up 10 ports so far, as we have to add each port to NAT manually. ie we cant add a range.

We still cannot connect, and here is the server log on our attempted connection :-

FileZilla Server version 0.9.41 beta
Copyright 2001-2012 by Tim Kosse (tim.kosse@filezilla-project.org)
Connecting to server...
Connected, waiting for authentication
Logged on
Retrieving account settings, please wait...
Done retrieving account settings
(007968)12/11/2014 10:55:16 - (not logged in) (81.174.131.44)> Connected, sending welcome message...
(007968)12/11/2014 10:55:16 - (not logged in) (81.174.131.44)> 220-FileZilla Server version 0.9.41 beta
(007968)12/11/2014 10:55:16 - (not logged in) (81.174.131.44)> 220 Welcome to HDS!!
(007968)12/11/2014 10:55:16 - (not logged in) (81.174.131.44)> USER anonymous
(007968)12/11/2014 10:55:16 - (not logged in) (81.174.131.44)> 331 Password required for anonymous
(007968)12/11/2014 10:55:16 - (not logged in) (81.174.131.44)> PASS *******
(007968)12/11/2014 10:55:16 - (not logged in) (81.174.131.44)> 530 Login or password incorrect!
(007968)12/11/2014 10:55:16 - (not logged in) (81.174.131.44)> disconnected.
(007969)12/11/2014 10:55:25 - (not logged in) (81.174.131.44)> Connected, sending welcome message...
(007969)12/11/2014 10:55:25 - (not logged in) (81.174.131.44)> 220-FileZilla Server version 0.9.41 beta
(007969)12/11/2014 10:55:25 - (not logged in) (81.174.131.44)> 220 Welcome to HDS!!
(007969)12/11/2014 10:55:25 - (not logged in) (81.174.131.44)> USER hdechem
(007969)12/11/2014 10:55:25 - (not logged in) (81.174.131.44)> 331 Password required for hdechem
(007969)12/11/2014 10:55:25 - (not logged in) (81.174.131.44)> PASS *******
(007969)12/11/2014 10:55:25 - (not logged in) (81.174.131.44)> 530 Login or password incorrect!
(007969)12/11/2014 10:55:25 - (not logged in) (81.174.131.44)> disconnected.
(007970)12/11/2014 10:55:33 - (not logged in) (81.174.131.44)> Connected, sending welcome message...
(007970)12/11/2014 10:55:33 - (not logged in) (81.174.131.44)> 220-FileZilla Server version 0.9.41 beta
(007970)12/11/2014 10:55:33 - (not logged in) (81.174.131.44)> 220 Welcome to HDS!!
(007970)12/11/2014 10:55:33 - (not logged in) (81.174.131.44)> USER hdechem
(007970)12/11/2014 10:55:33 - (not logged in) (81.174.131.44)> 331 Password required for hdechem
(007970)12/11/2014 10:55:33 - (not logged in) (81.174.131.44)> PASS *******
(007970)12/11/2014 10:55:33 - (not logged in) (81.174.131.44)> 530 Login or password incorrect!
(007970)12/11/2014 10:55:33 - (not logged in) (81.174.131.44)> disconnected.

Any more suggestions?

Many thanks
0
 

Author Comment

by:nigelbeatson
ID: 40437047
I have just reset the password to make sure there was no problem here, and tried to log in again. I get no password error, and here is the log for the attempted connection :-

(007981)12/11/2014 11:04:26 - (not logged in) (81.174.131.44)> Connected, sending welcome message...
(007981)12/11/2014 11:04:26 - (not logged in) (81.174.131.44)> 220-FileZilla Server version 0.9.41 beta
(007981)12/11/2014 11:04:26 - (not logged in) (81.174.131.44)> 220 Welcome to HDS!!
(007981)12/11/2014 11:04:26 - (not logged in) (81.174.131.44)> USER anonymous
(007981)12/11/2014 11:04:26 - (not logged in) (81.174.131.44)> 331 Password required for anonymous
(007981)12/11/2014 11:04:26 - (not logged in) (81.174.131.44)> PASS *******
(007981)12/11/2014 11:04:26 - (not logged in) (81.174.131.44)> 530 Login or password incorrect!
(007981)12/11/2014 11:04:26 - (not logged in) (81.174.131.44)> disconnected.
(007982)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> Connected, sending welcome message...
(007982)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> 220-FileZilla Server version 0.9.41 beta
(007982)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> 220 Welcome to HDS!!
(007982)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> USER hdechem
(007982)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> 331 Password required for hdechem
(007982)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> PASS *******
(007982)12/11/2014 11:04:36 - hdechem (81.174.131.44)> 230 Logged on
(007982)12/11/2014 11:04:36 - hdechem (81.174.131.44)> CWD /
(007982)12/11/2014 11:04:36 - hdechem (81.174.131.44)> 250 CWD successful. "/" is current directory.
(007982)12/11/2014 11:04:36 - hdechem (81.174.131.44)> TYPE A
(007982)12/11/2014 11:04:36 - hdechem (81.174.131.44)> 200 Type set to A
(007982)12/11/2014 11:04:36 - hdechem (81.174.131.44)> PASV
(007982)12/11/2014 11:04:36 - hdechem (81.174.131.44)> 227 Entering Passive Mode (192,168,1,7,82,50)
(007982)12/11/2014 11:04:36 - hdechem (81.174.131.44)> disconnected.
(007983)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> Connected, sending welcome message...
(007983)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> 220-FileZilla Server version 0.9.41 beta
(007983)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> 220 Welcome to HDS!!
(007983)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> USER hdechem
(007983)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> 331 Password required for hdechem
(007983)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> PASS *******
(007983)12/11/2014 11:04:36 - hdechem (81.174.131.44)> 230 Logged on
(007983)12/11/2014 11:04:36 - hdechem (81.174.131.44)> CWD /
(007983)12/11/2014 11:04:36 - hdechem (81.174.131.44)> 250 CWD successful. "/" is current directory.
(007983)12/11/2014 11:04:36 - hdechem (81.174.131.44)> TYPE A
(007983)12/11/2014 11:04:36 - hdechem (81.174.131.44)> 200 Type set to A
(007983)12/11/2014 11:04:36 - hdechem (81.174.131.44)> PASV
(007983)12/11/2014 11:04:36 - hdechem (81.174.131.44)> 227 Entering Passive Mode (192,168,1,7,82,51)
(007983)12/11/2014 11:04:36 - hdechem (81.174.131.44)> disconnected.
(007984)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> Connected, sending welcome message...
(007984)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> 220-FileZilla Server version 0.9.41 beta
(007984)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> 220 Welcome to HDS!!
(007984)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> USER hdechem
(007984)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> 331 Password required for hdechem
(007984)12/11/2014 11:04:36 - (not logged in) (81.174.131.44)> PASS *******
(007984)12/11/2014 11:04:36 - hdechem (81.174.131.44)> 230 Logged on
(007984)12/11/2014 11:04:36 - hdechem (81.174.131.44)> CWD /
(007984)12/11/2014 11:04:36 - hdechem (81.174.131.44)> 250 CWD successful. "/" is current directory.
(007984)12/11/2014 11:04:36 - hdechem (81.174.131.44)> TYPE A
(007984)12/11/2014 11:04:36 - hdechem (81.174.131.44)> 200 Type set to A
(007984)12/11/2014 11:04:36 - hdechem (81.174.131.44)> PASV
(007984)12/11/2014 11:04:36 - hdechem (81.174.131.44)> 227 Entering Passive Mode (192,168,1,7,82,52)

We see an entry in the bottom window indicating a connection in progress, but we still get a page cannot be displayed" in our browser when we try to connect.

I have attached a screenshot of the server admin console at the time of connection.
screenshot.png
0
 

Author Comment

by:nigelbeatson
ID: 40437054
Sorry I have just seen this :-

530 Login or password incorrect!

Any ideas?
0
 

Author Comment

by:nigelbeatson
ID: 40437072
Just noticed a couple of extra lines which appeared in the admin console at the end of that previously provided, as follows :-

(007988)12/11/2014 11:09:38 - hdechem (81.174.131.44)> 421 Connection timed out.
(007988)12/11/2014 11:09:38 - hdechem (81.174.131.44)> disconnected

This appeared around 5 mins after the initial events.

Many thanks
0
 
LVL 35

Expert Comment

by:Kimputer
ID: 40437076
The user has saved a wrong password before. Please clear these passwords in either IE or stored passwords in the User management in the control panel.
0
 

Author Comment

by:nigelbeatson
ID: 40437101
I reset the password for this user in the admin console, and I enter the password manually into the login box within IE.

I notice that the password is only indicated as being incorrect for the anonymous login, and the rest are accepted.

I dont recall setting up any security for an anonymous login, so am a little confused as to what I need to do.

Are you suggesting I rest the user password again for this user, and is there a different method I need to apply to reset the browser login? As I said, when the login box appears in IE, the username and password are balnk, and I enter them manually each time.

Do I need to configure the anonymous user somehow within the filezilla admin console?

Many thanks

Many thanks.
0
Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

 
LVL 35

Expert Comment

by:Kimputer
ID: 40437139
I'd almost suspect there's something wrong with the computer you're testing with. Can you use another computer or laptop?
Usually there should be a automatic LIST command in IE after a successful connect.
0
 

Author Comment

by:nigelbeatson
ID: 40437141
Since I have made changes to our filezilla admin console, I can no longer connect using a local copy of the filezilla client. I have tried using a specific port 21000 for example, but it still will not work.

I did not have any problems with local traffic, but could do with assistance to get local access re instated.

I have also opened up the ports 21000 to 21100 on the windows server firewall for TCP and I also tried UDP, but this has not helped.

Any help very much appreciated.

Many thanks
0
 

Author Comment

by:nigelbeatson
ID: 40437146
I have also noticed that whatever connection we try now, we are getting absolutely nothing showing in the filezilla admin console log, local or external.

Many thanks
0
 

Author Comment

by:nigelbeatson
ID: 40437418
Really desperate, can anyone help.

I have tried to set back the filezilla server to the pre change settings, but now I cannot get any of the local filezilla clients to connect to the server.

Unfortunately, I did not make a note of how the passive settings were prior to the change.

We now get this on the server :-

(000041)12/11/2014 14:16:15 - (not logged in) (192.168.1.24)> Connected, sending welcome message...
(000041)12/11/2014 14:16:15 - (not logged in) (192.168.1.24)> 220-FileZilla Server version 0.9.41 beta
(000041)12/11/2014 14:16:15 - (not logged in) (192.168.1.24)> 220 Welcome to HDS!!
(000041)12/11/2014 14:16:15 - (not logged in) (192.168.1.24)> USER dfs
(000041)12/11/2014 14:16:15 - (not logged in) (192.168.1.24)> 331 Password required for dfs
(000041)12/11/2014 14:16:15 - (not logged in) (192.168.1.24)> PASS dfs123
(000041)12/11/2014 14:16:15 - dfs (192.168.1.24)> 230 Logged on
(000041)12/11/2014 14:16:15 - dfs (192.168.1.24)> PWD
(000041)12/11/2014 14:16:15 - dfs (192.168.1.24)> 257 "/" is current directory.
(000041)12/11/2014 14:16:15 - dfs (192.168.1.24)> TYPE I
(000041)12/11/2014 14:16:15 - dfs (192.168.1.24)> 200 Type set to I
(000041)12/11/2014 14:16:15 - dfs (192.168.1.24)> PASV
(000041)12/11/2014 14:16:15 - dfs (192.168.1.24)> 227 Entering Passive Mode (192,168,1,7,142,201)
(000041)12/11/2014 14:16:15 - dfs (192.168.1.24)> MLSD
(000041)12/11/2014 14:16:26 - dfs (192.168.1.24)> 425 Can't open data connection.

and this on the Filezilla client :-

Command:      PASS ******
Response:      230 Logged on
Status:      Connected
Status:      Retrieving directory listing...
Command:      PWD
Response:      257 "/" is current directory.
Command:      TYPE I
Response:      200 Type set to I
Command:      PASV
Response:      227 Entering Passive Mode (192,168,1,7,142,201)
Command:      MLSD
Response:      425 Can't open data connection.
Error:      Failed to retrieve directory listing


I really need to get this working again, so forget the external connection for the moment, if anyone can advise on what is wrong, I would be much obliged.
0
 

Author Comment

by:nigelbeatson
ID: 40437434
Here is a screenshot of the passive settings.

Can anyone advise how these need to be set for just local connections via Filezilla clients?

Many thanks
passive.png
0
 

Author Comment

by:nigelbeatson
ID: 40437503
I notice that the early logs do not refer to "passive mode" at all.

Ever since I made changes to the Passive Mode settings, we have not been able to connect locally via filezilla client. How can I get rid of this?

I would just like to get our local users using filezilla client connected and working again.

Please help.

Regards
0
 
LVL 35

Expert Comment

by:Kimputer
ID: 40437798
Actually, proper passive mode settings were already mentioned in my earlier post:

You should set a passive port range in Filezilla server > Settings > Passive mode settings
 tick: Use Custom port range 21000 - 21100
 Default J(selected)
 Don't use ext ip (ticked)
 Now on your modem/router/firewall, add this port range (21000 through 21100) to forward to the server.

You can make it 10 ports only, as long as it matches your NAT firewall settings. If you keep this config, LAN usage is no problem.
0
 

Author Comment

by:nigelbeatson
ID: 40437924
thanks for your reply.

I worked to your instructions but unfortunately I could not get the new facility to work as required, but in addition it stopped my local filezilla clients from working.

I would just like to get the FTP service back to how it was before I started to change things around. ie I would like my filezilla clients to be able to connect to the local FTP server.

the logs at both ends keep referring to passive mode, which if you look at the early logs I uploaded, this was never detailed till after I changed things.

no matter how I try to return the setup back to how it was I just can't get it to work.

we have not changed anything on the filezilla clients, so it must be something that has changed on the server.

I don't think that the port redirection on our router should affect anything, or the changes I made to open up the windows firewall for the custom ports.

how can I get this operational, as it is causing problems for our users.

is there a way I can work through this to resolve this issue?

any help would be much appreciated.

thanks
0
 
LVL 35

Expert Comment

by:Kimputer
ID: 40438001
Just to be sure, I will attach a screenshot. With these setting, your server shouldn't have any problems on LAN connections at all (all my servers are like this, working both externally and internally)
These are actually the default settings (but with custom ports unchecked, it only means these will be chosen random).
ftp-passive.png
0
 

Author Comment

by:nigelbeatson
ID: 40438041
that's just how I have it set - without the custom ports selected.

so frustrating as I don't recall changing anything else.

why do we get messages about passive mode in the logs, as we never saw this in the first logs I posted?
the logs just look totally different now. I just don't understand it.
0
 
LVL 35

Expert Comment

by:Kimputer
ID: 40438074
Check again with the firewall of server temporarily disabled? If it works, you only need to focus on the firewall (set the custom ports again, make sure these ports are allowed in the firewall)
0
 

Author Comment

by:nigelbeatson
ID: 40438101
I will do as you suggest, but this all worked perfectly without any of those things configured previously.

how can the client connect with the server dissabled? have I miss understood?

thanks
0
 
LVL 35

Accepted Solution

by:
Kimputer earned 500 total points
ID: 40438121
Firewall, I said, temporarily disable the firewall on the server. You mentioned using Windows Firewall (the default firewall of windows), so just disable it for a minute, test FTP on LAN, and when it works, you know you have to check the firewall settings. If it still doesn't work, the problem is somewhere else.
0
 

Author Closing Comment

by:nigelbeatson
ID: 40464727
Many thanks!
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

This guide is intended for migrating Windows 2003 Standard with Exchange 2003 to Windows Small Business Server 2008. You will need the following: Exchange Best Practice Analyzer: http://www.microsoft.com/downloads/details.aspx?FamilyID=DBAB201F-…
The articles for turning off the Client firewall policy on the internet are for SBS 2008 and don't really help for SBS 2011. They actually moved the Client firewall policy. In 2011, the client firewall policy has moved to the SBS computers conta…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now