Group Policy Printer Deployment Not Working

Hi Everybody,

I am trying to deploy around 50 printers through group policy. The printers won't automatically add unless they have been previously added to the machine.

We have a 2003 domain controller and 2012 print server. All of our client machines have Windows 7 64 bit OS all with UAC disabled. I have setup the group policies through group policy manager installed on a Windows 7 machine. I have setup security groups for each printer in the domain controller. I have then setup the group policy to add the printer to any user in that group.

Group Policy settings:
Action - Update
Share path - \\PRINTSRV\PRT10
Item level targeting - "The user is a member of the security group Domain\PRT10"
Check box in - "user in group"

I have disabled point and print restrictions under computer and user configuration and made sure is applied to the parent folder of the domain computers and users but it does not seem to be taking effect.

Does anyone have any ideas?

Thank you,

 - Alex
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Do you have the correct print drivers loaded for the print server to dole out?
Joshua GrantomSenior Systems AdministratorCommented:
You must have Point and Print enabled and have "Do not show warning or elevation prompt" selected under "When installing drivers for a new connection"

I handled the printer automation project a couple of years ago. Took me a while to figure that out.
lipariAuthor Commented:
I have the latest PCL6 drivers installed for all models of the printers.

I have tried many variations of the point and print policy but I will try to change the policy to the settings you recommended again.
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Joshua GrantomSenior Systems AdministratorCommented:
Make sure your GPO is applied to a Users OU. Also, you must have Domain Computers added to Security Filtering if you have any settings set under Computer Configuration.
lipariAuthor Commented:
So far I have the same issue.

I tried changing the point and print settings which did not correct the issue.
I also added Domain Computer to the security filtering on the Point and Print group policy.
Do I need to wait for the settings to take effect?

An error I noticed on a client computer in the application event log is:
"The user 'PRT39' preference item in the 'PRT39 {ACB79787-190D-46A1-83F2-D11B3C9F382E}' Group Policy object did not apply because it failed with error code '0x80070bcb The specified printer driver was not found on the system and needs to be downloaded.' This error was suppressed."
Joshua GrantomSenior Systems AdministratorCommented:
From what it looks like, you do not have the compatible Win 7 64 bit driver installed as an additional driver on your Server 2012 Print server.
lipariAuthor Commented:
I took a screenshot of the drivers installed. All printers have both x86 and x64 drivers.
Joshua GrantomSenior Systems AdministratorCommented:
There may be a different driver for Windows 7 64-bit and Server 2012 64-bit

EDIT: Looks like you may need to look at installing v3 drivers as well to server Windows 7 clients
lipariAuthor Commented:
The drivers I added to the server were downloaded from Xerox's website for windows 7. There are different download options for server OS so I believe it is the correct driver.
Joshua GrantomSenior Systems AdministratorCommented:
Yea disregard my last post, I read that technet article incorrectly, I was on my phone.
Joshua GrantomSenior Systems AdministratorCommented:
Did you keep the Point and Print settings enabled?
Joshua GrantomSenior Systems AdministratorCommented:
If you have a testing PC, you can do a gpupdate /force to apply the new point and print settings to the client and then restart and login to see if the printers map

usually gpo settings update in random intervals of 90 minutes depending on your default domain policy.
lipariAuthor Commented:
The settings are still set to enabled.
When installing new drivers - Do not show warning or elevation prompt
When updating drivers - show warning only
Also I forgot to mention that all users are administrators on their computers.
lipariAuthor Commented:
I've been doing gpupdate /force to check the changes and no luck.
Joshua GrantomSenior Systems AdministratorCommented:
when you do a gpresult /r can you see that the point and print policy and the printer policy are applied?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lipariAuthor Commented:
Yes it says they are all applied. I actually believe it is working on all other machines except this one. I think we will go forward and finish migrating to the new 2012 server from the 2003 and see if we are still having issues. Thank you for your help.
lipariAuthor Commented:
Thank you for the assistance. It seems like it may actually be working which may have been the case all along minus the one troublesome computer. I will let you know otherwise.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.