Balancing RemoteApp Connections

Afternoon,

If I wanted my gateway server to manage my connection requests for remoteapp, what would be the best methodology to this?

Here is my current configuration:

Server A - Gateway/Connection Broker/RemoteApp server
Server B and C - RDSH servers

If I wanted incoming requests from, regardless of internal or external means. to be load routed evenly to each server, what would be the best practice to accomplish this in Windows?
victory2201Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

VB ITSSpecialist ConsultantCommented:
You can set up a load-balanced RD Session Host server farm, which will evenly spread the load between your two RDS hosts. The steps in this article should help you on your way: http://technet.microsoft.com/en-us/library/cc753891.aspx

If you run into any issues or have any questions, let me know.
0
Aaron TomoskySD-WAN SimplifiedCommented:
That's exactly the setup I run and with windows server 2012r2 it makes it very easy compared to 08. Here is the QuickStart for everything on one server
http://blogs.technet.com/b/yungchou/archive/2013/02/07/remote-desktop-services-rds-quick-start-deployment-for-remoteapp-windows-server-2012-style.aspx

And here is a much better walkthrough
http://msfreaks.wordpress.com/2013/12/09/windows-2012-r2-remote-desktop-services-part-1/
Another well written guide:
http://thewolfblog.com/2014/02/08/deploying-a-2012-2012r2-remote-desktop-services-farm/
0
MaheshArchitectCommented:
Assumed that you have 2012 \ 2012 R2 RDS servers
For internal network Gateway server will not come in picture
Once you logged on to RD web access server and clicked on published remote apps, the requests are directly routed to Session broker server and session broker will load balance those requests to available RD Session Host servers
If user has disconnected session, session broker point user to disconnected session.

If you are connecting to remote apps from internet, then only RD Gateway comes in picture. In that case user tries to access published remote apps on rd webaccess server, the requests are forwarded to RD Session broker via RD gateway server and again RD Session Broker server will load balance \ choose to which RDSH server requests to be forwarded

In any case RD Connection broker is responsible for load balancing \ connecting disconnected sessions.

In reality you should put connection broker on separate server in corporate network
RD web access and Gateway can be on one server and this server should be published on internet.

In days of 2008 R2 connection broker is limited to reconnect disconnected sessions and its not load balance incoming requests and in that case you do require NLB for RD Session Host servers
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Learn SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

victory2201Author Commented:
Thank you all for your comments.

VB, I followed that link you sent me and setup all requested functions within my environment.

When I am connecting through RemoteApp (this is being done through Control Panel > Remote Apps and Desktops) I can see the same application hosted twice from both RDSH servers in my farm. (Image A) I would like to have those be one icon, that can launch on either of the farm servers.

If I proceed by clicking on the icon, no matter how many logins there are to the application, it always wants to direct the connection back to my broker server and launch the application from there.
ImageA.png
0
MaheshArchitectCommented:
I think the problem exists with Connection Broker, as RD Web access get remote app collection information from Connection broker server and same is downloaded on client computers \ control panel \ remote apps
On your RD Connection Broker, check the following location and remove the registry key (after backing it up) that corresponds to old collection if any

HKLM\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Terminal Server\ CentralPublishedResources\ PublishedFarms\ <CollectionName>

Then refresh RD web access url, then delete all existing remote apps from desktop and again download fresh copy from rd web access and check.
0
victory2201Author Commented:
Mahesh,

You were correct, it was a problem with the settings on my connection broker. The remote apps are load balancing correctly now.

In regards to getting Control Panel > Remote Apps and Desktops working when outside my network, what approach should I take? I can already access the application by creating an rdp or msi, however I would still like for users to be able to download the remote apps to their local windows clients. When I try this now, I connect, however I never can get the application to come up. (basically sits at the initializing connection window)

There is always remote access page I can use, however I am trying to steer away from that if possible.
0
MaheshArchitectCommented:
So, you are using 2008 R2 RDS

If your applications are working from internet \ RDP file, it should work from control panel \ remote apps as well on win7 machines

Please try with new user profile and there download remote apps through control panel and check if they also stuck on initializing ?

Check below KB article
http://support.microsoft.com/kb/2601888

This has got most of the fixes
Choose one as per your problems (initialization failure)
0
victory2201Author Commented:
It was a configuration issue I had overlooked. We are all set now.

Appreciate the help on this issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.