oci_connect and oracle 9i

Hi,

I am using oci_connect to connect to an oracle 11 without problems, but oci_connect don't work with 9i, what i can do and how i can solve this problem?
LVL 1
joyacv2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

slightwv (䄆 Netminder) Commented:
I don't think it is oci_connect.  Likely the version of the client you have installed.

To connect to a 9i database, you'll need a pretty old Oracle client version.  Sorry but I don't know the exact version.
0
joyacv2Author Commented:
The oci_connect in php docs indicates that requires 10 and over
0
slightwv (䄆 Netminder) Commented:
Version 10g should connect to a 9i database.  I would expect 11g and higher to have problems.

What version do you have installed?

Finding a 10g client version is going to be problematic if you don't have it in-house somewhere.  Oracle has removed the 10g software from their site.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

joyacv2Author Commented:
i have the oracle 11 client on an ubuntu server and use php to connect to databases, so what i can do?
0
slightwv (䄆 Netminder) Commented:
I'm trying to find information on if the 11g client will connect to a 9i database.

While I look, what error message are you getting?
0
slightwv (䄆 Netminder) Commented:
Check out this document on Oracle Support:
Client / Server Interoperability Support Matrix for Different Oracle Versions (Doc ID 207303.1)

I cannot post any of the information if you don't have access to Oracle Support.
0
joyacv2Author Commented:
couldn't found driver
0
slightwv (䄆 Netminder) Commented:
Now that I've re-read the question, I might have misunderstood the problem.

Just to make sure I understand the problem:
You have an 11g client installed and are trying to talk to a 9i database using oci connect?
or
You have a 9i client installed trying to connect to a 9i database?
0
joyacv2Author Commented:
the first one, 11 client trying to talk to 9i database using oci_connect
0
slightwv (䄆 Netminder) Commented:
Since it states it cannot find the driver, I wonder if there is an issue with the install.

Was this a new install or the same machine doing connections to both an 11g and 9i database and the 11g works?
0
joyacv2Author Commented:
the connection always is to an 11 oracle database, this is the first time that I try to 9i, but which alternative i have if oci_connect cannot be used?
0
slightwv (䄆 Netminder) Commented:
I'm not a PHP person.

If the same app on the same server can connect to an 11g database and all you change is the database you are connecting to, I would not expect a "couldn't found driver" type error.

I would expect a version incompatibility type error.

I see some posts stating that you need 10g or above for EZConnect.  I see other posts stating oci_connect will work against 9i.

Are you using EZConnect?  If so, try the old tnsnames.ora method.

If it still doesn't work, please provide the exact error.
0
joyacv2Author Commented:
yes, I already try that, but don't found any tsnames explanation for ubuntu server 12.04 lts, do you know how to do that?
0
slightwv (䄆 Netminder) Commented:
tnsnames is an Oracle thing not an OS thing.

What is the connect string you are trying to use?

If you are using tnsnames there should be a file named tnsnames.ora on your server.  This is typically in $ORACLE_HOME/network/admin.  Where $ORACLE_HOME is the base folder where you installed the Oracle client.  You 'can' change the default but don't want to confuse the issue unless I have to.

Still not sure about your setup:
You have one server that can connect to 11g and you are trying to use that exact same server to connect to 9i and all you are doing is changing the connect strings?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
joyacv2Author Commented:
i have an ubuntu server 12.04 lts, with php, 11 oracle client, pci8 that connects to another server that have 11 oracle database, and i am trying to connect to another server that have a 9i oracle database
0
slightwv (䄆 Netminder) Commented:
OK, then the same server that works connecting to 1g database is failing when trying to connect to a 9i database.

That tells me that the client is installed correctly.

Still waiting for your connect string.
Still waiting for the exact error message.
0
joyacv2Author Commented:
i am out of office right now, i will give you the info as soon as i can, thank you very much!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.