Image with cache busting query string won't load from FTP site in IE11

My web site displays real-time instrumentation using an iFrame that takes content from an FTP server.  That content comprises a web page which references two images (which are also on the FTP server).

I have to pull the content from the FTP server - I have no control over its location and cannot easily copy it to a web server as it is updated every 20secs.

The web page loads into the iFrame fine and refreshes OK (it contains a JavaScript function to reload itself every 20secs).

The problem is with the two images that the page references. The application that generates those images (over which I have no control) adds a cache-busting query string to their URL (in the form image.jpg?dd/mm/yy). This obviously makes sense as the images change every 20secs but their size may not necessarily change so the cache-buster makes sure they are reloaded.

However, while the images load and reload in Firefox they don't in IE11 - IE11 doesn't seem to like query strings in FTP URLs.

Is this a known issue, and is there a work-around?

Thanks

Nigel
NAKBrooksAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dgrafxCommented:
I'm not specifically familiar with your issue but was reading somewhere that IE 11 changed the character encoding for URLs.
I am also not knowledgeable as to if this is what is affecting you.

Here is a link to read through about some of the IE 11 changes - does it fix your problem??? I don't know ...
http://singleconcept.wordpress.com/2013/12/10/internet-explorer-11-dont-call-me-ie/

What you could do is re-write the script_name gotten from the URL leaving off the query_string - then feed that URL to the browser - and if you need a cache-buster then add in your own but this time one that IE 11 and others will all work with.
0
NAKBrooksAuthor Commented:
Sorry that's not relevant to my issue. I've managed to sort out a workaround so I'll close this question.
0
NAKBrooksAuthor Commented:
Didn't resolve the issue but managed to persuade the data owner to load the data onto a website so I could link to it there, rather than from the ftp site.  This resolved my issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

dgrafxCommented:
What is your workaround?
0
NAKBrooksAuthor Commented:
Data now on web site so no need to link to ftp site therefore issue doesn't arise.
0
dgrafxCommented:
You beat me posting the last comment ...
0
NAKBrooksAuthor Commented:
Issue resolved by workaround.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.