?
Solved

Office WebApps Server Error in '/x' Application

Posted on 2014-11-13
7
Medium Priority
?
3,455 Views
Last Modified: 2014-11-19
I am getting the following error when I attempt to open any MS Office Document within our SharePoint 2013 Foundations site. Help!

See Image for Runtime Error. It occurs on the web page.
2014-11-13-15-41-59.jpg
0
Comment
Question by:Robert Mohr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
7 Comments
 
LVL 28

Expert Comment

by:Dan McFadden
ID: 40449864
I would edit your web.config so you can see the actual error message.  Modify the following line of your config file:

<customErrors mode="RemoteOnly">

Open in new window


to this:

<customErrors mode="Off">

Open in new window


Or, if you do not want to do this, logon to the server where this application lives and try to go to the URL which is giving you the error.

Please post the error full text of the error message.

Dan
0
 

Author Comment

by:Robert Mohr
ID: 40450032
Dan -

Thank-you for your help with this!

Where is the config file located? I attempted to do research (google) with no luck. I logged into IIS but I'm not sure where to go.

In regards to where the application resides, I entered the URL of the file and it still gave the same error
URL of file was http://<servername>/Shared%20Documents/test.xlsx?Web=1

Couple things to note -
When I deployed the single server office web apps server to use HTTP, I entered this line into PowerShell
New-OfficeWebAppsFarm -InternalURL "http://<servername>" -AllowHttp -EditingEnabled

When running above PowerShell command, I get a notice that says "You should only do this if users of this office web apps server have licenses that permit editing using office web apps." I went ahead and chose "Yes" even though I'm not sure what that means. Everyone has a copy of Office on their machines.

It's also worth noting that I received positive installation verification when entering the following link into a browser http://servername/hosting/discovery after I set up the webapps farm.

Here is configuration information -
My webapps server is Server 2008R2 (IIS 7)
SharePoint server is Server 2012R2 (IIS 8)
I'm considering putting SharePoint on Server 2008R2 so there's is a closer match with server and IIS.
My version of is SharePoint 2013 Foundations
I'm using this TechNet article to set up my webapps server. http://technet.microsoft.com/en-us/library/jj219455(v=office.15).aspx

Thoughts?
0
 
LVL 28

Accepted Solution

by:
Dan McFadden earned 2000 total points
ID: 40450109
in IIS manager, go to the website that hosts the application, switch to content view and you should see the contents of the web application.  There should be a web.config there.

Then right-click on the site, select "manage website" and click "Advanced Settings."  There is a field called "Physical Path," that is where the web.config resides.
0
Percona Live Europe 2017 | Sep 25 - 27, 2017

The Percona Live Open Source Database Conference Europe 2017 is the premier event for the diverse and active European open source database community, as well as businesses that develop and use open source database software.

 

Author Comment

by:Robert Mohr
ID: 40450300
Dan

Thanks for assisting finding webconfig file(s).

No luck on that change however. The webconfig files on the SharePoint server had
<customErrors mode="On">
which I then changed to
<customErrors mode="Off">
I searched the WebApps server to see if the config file there even had <customErrors mode="Off"> and it had no customErrors line.

I have rebooted both my WebApps Server and my SharePoint Server.

Any further insight?
0
 

Author Comment

by:Robert Mohr
ID: 40450313
It may be worth noting that when I now go to
http://<servername>/hosting/discovery
that I get a 404 error and the configuration verification page does not show. Augh!!!!!
0
 

Author Comment

by:Robert Mohr
ID: 40450319
Scratch that last comment please. No 404.
0
 

Author Closing Comment

by:Robert Mohr
ID: 40453527
This helped find the path to a webconfig file. thank-you!
0

Featured Post

Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction This article explores the design of a cache system that can improve the performance of a web site or web application.  The assumption is that the web site has many more “read” operations than “write” operations (this is commonly the ca…
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question