Hyper-V Ms won't start after updates and reboot

I need some help.
I installed the November 2014 MS updates last night. I installed them on my lab Hyper-V box. The Hyper-V box is joined to a domain but is not a domain controller. It is Server 2012R2 with Hyper-V with all previous patches applied. I had two VMs configured on the box. The VMs were a 2012R2 server and a Windows 8.1 box. Both were running fine. In fact I shut them down before I did the Microsoft Updates on the server.
The issue I describe below was not present until I did the updates and rebooted. The server and the associated VMs had been running fine for months. These updates are the ones that my SUS server provided to this server.
After I rebooted the server I could not restart either VM. I kept getting the same error that is listed below. I tried DELETING the VM from Hyper-V manager and then building a new VM and using the old vhdx. Again NO LUCK. I even tried CREATING a new VM and I got the same problem.
(Additional Note: I appeared as though I was able to delete the VM from Hyper-V Manager. Hyper-V Manager displayed 'Destroying....' for some period of time and then the VM was removed from Hyper-V Manager. However, recreating the VM did not solve the problem.)
Each time I get the following error displayed on screen.
'Unnamed VM' could not intiialize.
An attempt to read or update virtual machine configuration failed
'Unnamed VM' could not initialize (Virtual Machine ID)
'Unnamed VM' could not read or update virtual machine configuration: Ran out of memory (0x8007000E) Virtual machine ID B9xxxxxxxxxxxx
=======================

I adjusted permissions on the C:\ProgramData\Microsoft\Windows\Hyper-V folder. Opened it up to "Authenticated Users" based on a couple of TechNet articles that I found. NO luck
In the Hyper-V Config log I get the following entry,
The configuration store at'' is not accessible Unspecified error(0x80004005)
==========================
I also had these errors in the Windows Application log.
ID=1000 Source=Application Error Type=1 Message=Faulting application name: vmwp.exe, version: 6.3.9600.17334, time stamp: 0x5407c751
Faulting module name: vsconfig.dll, version: 6.3.9600.16384, time stamp: 0x5215db66
Exception code: 0xc0000194
Fault offset: 0x000000000001966c
Faulting process id: 0xb84
Faulting application start time: 0x01cffe274d55ea6b
Faulting application path: C:\Windows\System32\vmwp.exe
Faulting module path: C:\Windows\System32\vsconfig.dll
Report Id: d4210450-6a1a-11e4-80d6-0019b9eed814
Faulting package full name:
Faulting package-relative application ID:
LVL 2
Dale McKayGlobal Principal ArchitectAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
Look at your disk space. One thing Hyper-V does is reserve as much disk space on the drive as you've allocated RAM for the VM. So a VM with 32 gigs of RAM needs 32 gigs of free space just to start. Hence the "ran out of memory."  It seems likely that you were already on the verge of being out of space and the latest updates put you just over the edge.
0
Dale McKayGlobal Principal ArchitectAuthor Commented:
OK,,I like your thinking.

So I went and checked. The drive that the VMs,,,and Hyper-V,, are on has 72 GB free.

I went and looked at the configured memory requirements for the VMs.  Both VMs are configured for 512 MB of startup memory and they initially weren't configured for Dynamic Memory. I went ahead and configured Dynamic Memory on both giving them 512MB Minimum and 8192 MB Maximum settings.

Still no start. Error message is the exact same.
0
Cliff GaliherCommented:
Check your other drives. There is a logic to the scratch disk that is chosen, but it isn't immediately coming to mind and I'm mobile so I can't google it at the moment.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Dale McKayGlobal Principal ArchitectAuthor Commented:
This server only has one hard drive. Not sure where the scratch disk would be...
0
Cliff GaliherCommented:
What OSes are your guests?
0
Dale McKayGlobal Principal ArchitectAuthor Commented:
. I had two VMs configured on the box. The VMs were a 2012R2 server and a Windows 8.1 box. Both were running fine. I
0
Cliff GaliherCommented:
Try setting the memory for the 2012 R2 VM to 2048MB, disable dynamic memory, and try starting it.  512MB is really too small for the OS to load, and since both 2012 R2 and 8.1 have integration components preinstalled, they will report memory errors up to the host. I'm surprised they were running at all with that little memory. The latest 2012 R2 installer ISO won't even boot with less that a gig.
0
Dale McKayGlobal Principal ArchitectAuthor Commented:
Ok,,did that. 2048MB for startup. No Dynamic Memory. No change. VMs still won't start. Same exact error.

Remember that these VMs were running prior to November 2014 updates being applied to the Hyper-V host. I had no issues with these VM s starting or running...
0
Cliff GaliherCommented:
I kept that in mind. Like I said, integration components can still play a role, so even a host update can cause VMs to behave differently.

But if they aren't starting now, I'm at a loss. The only other thing I can think of is if the host is domain joined and the only DC is a guest. That could cause issues with updates trying to write config data with an account that can't authenticate. But I wouldn't expect that to present with a memory error.
0
Dale McKayGlobal Principal ArchitectAuthor Commented:
The DC for this domain is not a guest on this Hyper-V server. The 2012R2 virtual on this server is just a "play" server where I can try things and break things.

Thanks for the help but I am really focusing on the updates that were done. One of them is an XML update and since the VM configs are in XML form that might make sense.

Thanks again....
0
Dale McKayGlobal Principal ArchitectAuthor Commented:
OK,,,doing some more digging.

Had an issue on this box where I couldn't start VMs. This,, http://support.microsoft.com/kb/2779204,, solved my problem.

Now when I look at my Local Security Policy on the Hyper-V server,,I see some settings that are updated by my "Default Domain Policy" which is the only policy in play for this domain. HOWEVER, my Default Domain Policy disables the administrator account and on this Hyper-V server box the administrator account is enabled and remains that way even after a "gpupdate /force".

I am pretty certain that this whole issue comes down to a permission issue in some way so I am kinda grasping at straws right now....

I do see that NT VIRTUAL MACHINE\Virtual Machines is configured to "Log on as a service" in the Local Security Policy on this Hyper-V server
0
David Johnson, CD, MVPOwnerCommented:
create a dummy virtual machine and see if it starts
0
Dale McKayGlobal Principal ArchitectAuthor Commented:
Yeah,,tried that. Same error as the previously existing VMs.
0
McKnifeCommented:
I would question the health of the hyper-v-components, not of the guest machines.
Do a repair installation using the setup media (it's called an inplace upgrade). This will undo all updates as well.
0
Dale McKayGlobal Principal ArchitectAuthor Commented:
OK,,so I solved this issue by removing the Hyper-V role and then readding the role. The permissions of C:\Programdata\Microsoft\Windows\Hyper-V and C:\Users\Public\Documents\Hyper-V definetly changed as a result of re-adding the role.

All required updates (as supplied by WSUS) are applied also.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dale McKayGlobal Principal ArchitectAuthor Commented:
OK
0
Dale McKayGlobal Principal ArchitectAuthor Commented:
I solved my own problem
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.