Solved

Deploying a wcf application

Posted on 2014-11-14
3
95 Views
Last Modified: 2014-11-25
Hi. I have a WCF service published and this is my connectionstring  to the database.
<add name="DBEntities" connectionString="metadata=res://*/ServContexto.csdl|res://*/ServContexto.ssdl|res://*/ServContexto.msl;provider=System.Data.SqlClient;provider connection string=&quot;data source=10.1.1.71;initial catalog=DB;persist security info=True;user id=usr_xxx;password=YYYYYYYYY;MultipleActiveResultSets=True;App=EntityFramework&quot;" providerName="System.Data.EntityClient" />

another connectionstring "Provider=SQLOLEDB;SERVER=10.1.1.71;DATABASE=producao;UID=homologacao;PWD=ZZZZZZZZZ;"

using the first connection with my wcf service, I got a error 500. and the second, a legacy application works fine.

basically the difference is the provider. how my publish could upload the sqlclient provider?

I have a test method that does not use the database and it works ok. only the methods that use the database fail.

thx in advance.
0
Comment
Question by:Deraldo Silva
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 75

Expert Comment

by:käµfm³d 👽
ID: 40443416
Try turning on the display of custom errors so that you can see what the underlying issue is. Modify your web.config with the information found here:

http://msdn.microsoft.com/en-us/library/h0hfz6fc(v=vs.85).aspx

Spceficially, setting customErrors to off should allow you to see the exception detail. You'll need to turn on debug mode as well:

http://msdn.microsoft.com/en-us/library/e8z01xdh.aspx

Be sure to remove these added settings before you go to production!
0
 

Accepted Solution

by:
Deraldo Silva earned 0 total points
ID: 40456827
Hi.
The problem occurred because the sql server native client was not installed.
It comes with sql server as in http://msdn.microsoft.com/pt-br/library/ms131321(v=sql.110).aspx
and from here https://www.connectionstrings.com/download-sql-server-native-client/

thx for your attention
0
 

Author Closing Comment

by:Deraldo Silva
ID: 40464129
After install the missing component, the deploy works fine.
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to leverage one TLS certificate to encrypt Microsoft SQL traffic and Remote Desktop Services, versus creating multiple tickets for the same server.
What to do when Windows Update is not working correctly? What tools can I use to detect the cause of the malfunction problem? What does this numeric error code mean? These and other questions that you have been asking in the past are answered here (…
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question