WordPress How do I remove the ability to comment on my static front page?

WordPress How do I remove the ability to comment on my static front page?

And how do I get into the code for themes and templates?
padmasambhavaAsked:
Who is Participating?
 
Jason C. LevineNo oneCommented:
You almost got it, but misinterpreted what those checkboxes do.

When you are editing a page/post/media item/whatever the "Screen Options" control which metaboxes you can see.  In turn, the metaboxes have controls and/or content options that affect the current page/post.

So go back to the edit screen, open Screen Options and check both Discussion and Comments.  New metaboxes should appear below the content editor.

In the Discussions metabox, uncheck everything. In the Comments metabox, delete any comments that are there.  Then save the page.
0
 
Jason C. LevineNo oneCommented:
WordPress How do I remove the ability to comment on my static front page?

Edit the page in the backend and find the Discusssion metabox.  Disable comments.

And how do I get into the code for themes and templates?

Appearance | Editor
0
 
padmasambhavaAuthor Commented:
Page in the backend? Discussion in metabox? Where are these things?

Appearance / Editor - Bingo! Thanks!
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Jason C. LevineNo oneCommented:
Page in the backend? Discussion in metabox? Where are these things?

Edit the page in question.
0
 
padmasambhavaAuthor Commented:
When I edit the page I see Screen Options at the top which has some promising checkboxes.

Show on screen
Revisions Custom Fields Discussion Comments Slug Author Page Attributes Featured Image
Screen Layout
Number of Columns: 1 2

I have unchecked Comments, updated, and then Published the page. I still have comments. On the page it still has "Leave a Reply" and a submit button for comments.
0
 
padmasambhavaAuthor Commented:
When I edit the page I see Screen Options at the top which has some promising checkboxes.

Show on screen
Revisions Custom Fields Discussion Comments Slug Author Page Attributes Featured Image
Screen Layout
Number of Columns: 1 2

I have unchecked Comments, updated, and then Published the page. I still have comments.
0
 
Jason C. LevineNo oneCommented:
Is the above a mistake?  Did you read my reply?
0
 
padmasambhavaAuthor Commented:
Oops, sorry I misinterpreted. It works! Thanks!
0
 
padmasambhavaAuthor Commented:
I have another WordPress question about how to allow more than one post on a page. I'd really appreciate it! No one has commented.
0
 
Jason C. LevineNo oneCommented:
Link?
0
 
padmasambhavaAuthor Commented:
0
 
Jason C. LevineNo oneCommented:
No, the link to your other question.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.