Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

can't browse computes on the network

Posted on 2014-11-15
11
Medium Priority
?
190 Views
Last Modified: 2014-12-11
There is a network with about > 10 PCs (WIndows 7 Pro) without a file server.
When I open "My Computer" and choose "Network" on left window pane, I can't see ANY COMPUTER listed.
I thought when you install WIndows 7, by default, network device discovery function is enabled. Apparently it is not on any of the computers on this particular network.
Also when I ping a particular PC on the network by computer name, it does not give me 192.168.1.x. Instead of it displays long numbers and digits with a lot of ":".
How can I display computers on the network and how can I display IP v4 address when I ping the computer name?
0
Comment
Question by:sglee
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +3
11 Comments
 
LVL 24

Accepted Solution

by:
VB ITS earned 1000 total points
ID: 40445298
I thought when you install WIndows 7, by default, network device discovery function is enabled. Apparently it is not on any of the computers on this particular network.
Network discovery is actually disabled by default for Public Networks in Windows 7. If the Network type is set to Work or Home then it should be enabled. You will need to check the type of Network the PCs are on. You can enable Network Discovery using the steps in this article: http://windows.microsoft.com/en-au/windows/enable-disable-network-discovery#1TC=windows-7

Also when I ping a particular PC on the network by computer name, it does not give me 192.168.1.x. Instead of it displays long numbers and digits with a lot of ":".
How can I display computers on the network and how can I display IP v4 address when I ping the computer name?
Sounds like the PCs are getting an IPv6 address from a DHCP server. You'll need to log into whatever device that is handing out the IP addresses (generally a router or server) and disable the DHCP scope for IPv6. Without actually knowing what device is handing out IPs though, I can't really give you any further info to disable it.

To find the IP address of your DHCP server, type ipconfig /all | findstr /C:"DHCP Server" in Command Prompt on one of the PCs and it will return with the IP address of your DHCP server.
0
 
LVL 31

Assisted Solution

by:Predrag
Predrag earned 1000 total points
ID: 40445377
Sounds like the PCs are getting an IPv6 address from a DHCP server.
No, they are not. Network cards get their own IPv6 address from OS.
IPv6 don't need DHCP for local network, those are link-local addresses and start with fe80::/10 and last half of the address is randomized in case of Microsoft.
0
 
LVL 71

Expert Comment

by:Qlemo
ID: 40445708
And why do you think you should have 192.168.1.x addresses? Is there a DHCP server? Or do you assign IPs manually?
0
Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

 

Author Comment

by:sglee
ID: 40445760
I have not set up this particular network. When I was onsite first time, I saw 12 workstations with no file server. When I type IPCONFIG, I see gateway address to be 192.168.1.1 which is also DHCP server, but I can not get into it.
I suspect this is Time Warner Internet service provider's cable modem. I can run IPCONFIG and determine IP address of each PC, but pinging by computer name does not return typical v4 IP address in 4 Replies.
Let me try the suggestions above and post the result.
0
 
LVL 31

Assisted Solution

by:Predrag
Predrag earned 1000 total points
ID: 40445768
You use IPv4 and IPv6 addresses.

To ping with ipv4 address you can
ping -4 <hostname>

For discovery of IP addresses on unknown network I usually use Advanced IP scanner v1.5 there is a newer version but it is much slower.
0
 

Author Comment

by:sglee
ID: 40445814
Network Discovery@VB ITS
I discovered that "Network discovery" was not turned on. So I turned it on and clicked [Save changes] button as shown in the screenshot. However it does not keep the change.
I tried to turn it on for both HOME and PUBLIC, but the computer simply refuses to keep the change. It goes back to "OFF".
0
 

Author Comment

by:sglee
ID: 40445817
@PredragNetwork
when I added -4 in PING command, it returned a v4 IP address.
 
C:\Users\Administrator>ping cassi-pc
 
Pinging Cassi-PC [fe80::911f:cbee:ee5c:cd79%11] with 32 bytes of data:
Reply from fe80::911f:cbee:ee5c:cd79%11: time<1ms
Reply from fe80::911f:cbee:ee5c:cd79%11: time<1ms
Reply from fe80::911f:cbee:ee5c:cd79%11: time<1ms
Reply from fe80::911f:cbee:ee5c:cd79%11: time<1ms
 
Ping statistics for fe80::911f:cbee:ee5c:cd79%11:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
 
C:\Users\Administrator>ping -4 cassi-pc
 
Pinging Cassi-PC [192.168.1.138] with 32 bytes of data:
Reply from 192.168.1.138: bytes=32 time<1ms TTL=128
Reply from 192.168.1.138: bytes=32 time<1ms TTL=128
Reply from 192.168.1.138: bytes=32 time<1ms TTL=128
Reply from 192.168.1.138: bytes=32 time<1ms TTL=128
 
Ping statistics for 192.168.1.138:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
0
 
LVL 31

Expert Comment

by:masnrock
ID: 40448961
You could go to the network settings on each workstation, and turn off IPv6.
0
 
LVL 24

Assisted Solution

by:VB ITS
VB ITS earned 1000 total points
ID: 40448968
@VB ITS
I discovered that "Network discovery" was not turned on. So I turned it on and clicked [Save changes] button as shown in the screenshot. However it does not keep the change.
I tried to turn it on for both HOME and PUBLIC, but the computer simply refuses to keep the change. It goes back to "OFF".
Make sure the following services are Started:
DNS Client
Function Discovery Resource Publication
SSDP Discovery
UPnP Device Host
Try enabling Network Discovery again.
0
 
LVL 59

Expert Comment

by:LeeTutor
ID: 40495341
I've requested that this question be deleted for the following reason:

Not enough information to confirm an answer.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question