Solved

VLANS

Posted on 2014-11-17
1
83 Views
Last Modified: 2015-11-16
Totally not savvy with the in depth details of network but I have a question.

All my office network was on a single network range 192.x.0.x

I recently had some control4 equipment installed and this resolutely refused to play with my cisco 320 VOIP unit.

Overloaded my router and throwing IP addresses out all over the place.

Dont really know why - control4 dont either - but the long and short of it is that I dont have the time or the skill to work out why either.

Resolution was to put the "network", the control4 and the phones all on separate vlan

Problem being that the control4 needs to access my NAS on the 192.x.0.x range and is now on 192.x.2.x range.

Simple - I enabled those two vlans to recognise themselves and everything is working fine.

Basically the cisco phone system is only allowed to talk to itself and that is also working fine.

Problem I now have is that a couple of the computers in the office get their internet access through the phones and of course they are being allocated 192.x.3.x ip ranges - which is not allowed to see the 192.x.0.x range at all.

If I set up my system as follows:

192.x.0.x is the majority of the things we have - cctv etc
192.x.2.x is the control4 system
192.x.3.x is the cisco VOIP system

Allow 2.x to see 0.x - which is working fine.

If I now allow 3.x to see 0.x range will that keep the control4 and the cisco voip systems unable to see each other but allowing my computers connected to through the cisco phones to see the NAS located on the 192.x.0.x range.

I really hope I made myself clear! Apologies if I did not.
0
Comment
Question by:roblickley
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 30

Accepted Solution

by:
Predrag earned 500 total points
ID: 40447014
I don't know what Cisco switch do you have but, this should work.
On ports with phones you need to set VOICE and data subnets.
PC-s don't need to be in same network as PC.

Under port configuration mode
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan <vlan-id > //your data network
Switch(config-if)# switchport voice vlan {vlan-id | dot1p | untagged | none}

So, both of your networks will be present. Data and Voice.

You can set also QoS
Switch(config)# mls qos
Use the following steps to configure Auto-QoS:
switch(config-if)# auto qos voip {cisco-phone | cisco-softphone | trust}
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses
Course of the Month3 days, 17 hours left to enroll

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question