The application was unable to start correctly (0XC0150002).

I have an application that installs correctly however once I tried to start the program I get the message "The application was unable to start correctly (0xc0150002). Click okay to close the application."

Any ideas as to what could be going on here?

Thank you
Pat ClancyCEOAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Might be a dependency error.  What application is it?  Do you find any entries in the event log?

Pat ClancyCEOAuthor Commented:
The application is "Diet Power" and it is a database type program. I will check the logs. I have the computer doing all of the Windows updates right now.

Pat ClancyCEOAuthor Commented:
I have for more information to add to this question. The following is a cut and paste from the event viewer.

Activation context generation failed for "C:\Program Files\DietPower 4.4\DietUtil.dll". Dependent Assembly Microsoft.VC80.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.6195" could not be found. Please use sxstrace.exe for detailed diagnosis.

Thank you for your help
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

Pat ClancyCEOAuthor Commented:
Thank you,

I have downloaded the above file and installed it then reinstalled the program and am still getting the same error message.

Depending on your version of Windows, ensure that you do not have the Visual C++ x64 Redistributable installed.

Another possibility is that I gave you the link to the wrong version.  :(

Here is the link to the Microsoft Visual C++ 2005 Service Pack 1 Redistributable -

When you download that, ensure that you install the vcredist_x86.exe.

Pat ClancyCEOAuthor Commented:
Thanks but no Joy in Mudville....
What operating system are you using?

Pat ClancyCEOAuthor Commented:
Windows 7 Pro, X86.
Ok a couple of possible resolutions.

First one, try setting the compatibility mode.
1. Right click on the icon used to start this application
2. Go to properties
3. Choose compatibility
4. Choose to run compatible with Windows XP SP2
5. Click on okay

Second one, (if the first does not work), reload the Side-By-Side installation for VC++ Redistributable:

Pat ClancyCEOAuthor Commented:
Thank you for your help,

Here's what I ended up having to do:
1. Completely uninstall all versions of the redistributable
2. Completely uninstall diet power
3. Reboot
4. Reinstall the 2005 redistributable
5. Reinstall diet power

I don't know what effect this is going to have one the other programs but since this is a new installation I should build is reinstall any programs that require the 2008 and 2013 versions of the redistributable.

Thank you for your help.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pat ClancyCEOAuthor Commented:
We had to fumble around quite a bit to find a solution for this situation.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.