Lost administrative previliege in WIndows 7 account

error 1Error 2Adding admin previlegeControl Panel - User AccountsHi,
 
 I have a windows 7 Pro PC where the current user account lost its administrative privilege all of a sudden.
 In compmgmt.msc, I tried to add "administrators" to its group, but it fails. Please see the screenshots.

 I tried to activate(unlock)  native administrator account in compmgmt.msc, I got an error "access is denied".
 When I tried to create a new account, I got an error  "access is denied".

 I opened control panel/User accounts and tried to add a new account "User" there, but I got an weird error like "The specified account name is not valid ...". Please see the screenshot above.

 What can I try next?

Thanks.
LVL 1
sgleeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Adam LeinssServer SpecialistCommented:
Have you tried logging in as "Administrator" in safe mode and then add the account from there?
0
sgleeAuthor Commented:
Like I said, the administrator account, by default, disabled. When I tried to enable it, I got an error.
So even if I can restart the computer in SAFE mode, how am I going to log in as administrator?
0
jcimarronCommented:
sglee--
Run a System Restore to a date before the problem started.

Concerning the last screenshot, are you certain the account name does not contain any of the unacceptable characters?
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

sgleeAuthor Commented:
I just tried to open account type from Standard user to Administrator. When I clicked [Apply] after selecting Administrator, there was no error. However when I go back to the same screen, current account shows as "Standard user". It simply does not save the change.
0
Adam LeinssServer SpecialistCommented:
Generally, you can use the Administrator account even if it is disabled in safe mode.
0
sgleeAuthor Commented:
Advanced Recovery OptionI can't even go back to previous recovery point.

"Concerning the last screenshot, are you certain the account name does not contain any of the unacceptable characters? " ---> the new user name that I was trying to create was "user".
0
sgleeAuthor Commented:
"Generally, you can use the Administrator account even if it is disabled in safe mode. " --->
If that is true, then I will go onsite tomorrow to try to log as Administrator in Safe Mode.
0
Adam LeinssServer SpecialistCommented:
May want to make a copy of this bootdisk "just in case" as well:

http://pogostick.net/~pnh/ntpasswd/

That will allow you to reset/enable the Administrator account as long as the disk is not encrypted.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeCommented:
"Generally, you can use the Administrator account even if it is disabled in safe mode" - of course this is just a misunderstanding and not true. the bootdisk however would help.
0
sgleeAuthor Commented:
@Adam,

  That article is long. Can you give me the link where I need to download the program and exact steps to follow to create a bootable password reset USB?
0
Adam LeinssServer SpecialistCommented:
I apologize.  This trick only works for Windows XP in safe mode.  I just tried it on Windows 7 and it doesn't work anymore.   You will need to use the ntpasswd disc to re-enable the account.
0
sgleeAuthor Commented:
can you give me specific steps for " ntpasswd disc"? I have not used it before.
0
Adam LeinssServer SpecialistCommented:
Just unzip this, burn it as a CD image to a CD: http://pogostick.net/~pnh/ntpasswd/cd140201.zip

You should be able to disable the Administrator account on a test computer (make a backup account first!) and then try it.  It is a bootable disc, you just boot to the disc and follow the prompts.
0
sgleeAuthor Commented:
CD140210_ISOI burned the image to the CD. Let me try this on a test PC.
0
sgleeAuthor Commented:
When I start the computer with this CD in CD-ROM, I see the following screen.
Initially I was looking at BOOT: prompt and after a while, it keeps saying "Invalid or corrupt kernel image". Am I supposed to type in something?
0
jcimarronCommented:
sglee--
"I can't even go back to previous recovery point."  You said that in an earlier post. http:#a40448536   And showed a screen shot of System Image.

 I suggested that you run System Restore--Not a System Image.
http://windows.microsoft.com/en-us/windows7/products/features/system-restore
0
jcimarronCommented:
sglee--
"Invalid or corrupt kernel image "
Are you running Ubuntu/Linux?

There comes a time after so many different problems and error messages that you may want to consider a Repair Install.
http://www.sevenforums.com/tutorials/3413-repair-install.html
This will not affect your personal data or installed programs, but you may want to consider a backup first.
0
Adam LeinssServer SpecialistCommented:
Hmm...that should have worked...maybe use IMGBURN to burn it as a bootable disc?

http://www.imgburn.com/
0
sgleeAuthor Commented:
@jcimarron
this computer has windiws 7 pro. I will look into repair install if I can not get it going in safe mode.
0
sgleeAuthor Commented:
@adam
Say I got in on the CD correctly and started the computer. What should I expect to happen or see?
0
Adam LeinssServer SpecialistCommented:
Should look like a DOS type text based interface...it should ask you a bunch of questions about what you want to do.
0
sgleeAuthor Commented:
@Adam,

  http://www.imgburn.com/
  I don't trust this website. It looks like it will try to download something else along with real program ... I will use what I have.
0
sgleeAuthor Commented:
@Adam
Can I burn this ISO into USB?
0
Adam LeinssServer SpecialistCommented:
This is from the author's site:

Copy all the files that is inside the usbXXXXXX.zip or on the CD onto an usb drive, directly on the drive, not inside any directory/folder.

It is OK if there are other files on the USB drive from before, they will not be removed.

Install bootloader on the USB drive, from command prompt in windows (start the command line with "run as administrator" if possible)

X:syslinux.exe -ma X:

Replace X: with the drive letter the USB drive shows up as (DO NOT USE C:)

If it seems like nothing happened, it is usually done.

However, a file named ldlinux.sys may appear on the USB drive, that is normal.
It should now in theory be bootable.
0
sgleeAuthor Commented:
you know .. I did not think about this.
But even if I can reset administrator password, it won't help because the problem here is that current user account has been switched from administrator type to standard on its own.
Currently, by default, administrator account is "disabled". I can't enable it because "access is denied - error 5". So even if I manage to get the password changed to something else, as long as I can't enable administrator's account, it won't do any good.
Tomorrow if I can't do anything in SAFE mode, I will suggest that we restore the computer to the factory setting or re-install OS from the scratch.

Thank you all.
0
Adam LeinssServer SpecialistCommented:
This is a utility to reset the password of any user that has a valid local account on your Windows system.

Supports all Windows from NT3.5 to Win8.1, also 64 bit and also the Server versions (like 2003, 2008, 2012)

You do not need to know the old password to set a new one.

It works offline, that is, you have to shutdown your computer and boot off a CD or USB disk to do the password reset.

Will detect and offer to unlock locked or disabled out user accounts!

There is also a registry editor and other registry utilities that works under linux/unix, and can be used for other things than password editing.
0
sgleeAuthor Commented:
CD140201ISO@Adam
OK. I will try it one more time today on a test PC. Here is what I am going to do.
(1) Setup Win7 Pro on a test PC.
(2) Create default account "User" during setup process and assign a password.
(3) After installation, I will confirm that "Administrator" account is DISABLED by going into compmgmt.msc.
(4) Create a CD off http://pogostick.net/~pnh/ntpasswd/
(5) Start the test PC from CD.

One strange thing is, now I have done this twice yesterday, whenever I burned a bootable CD off cd140201.iso, it stops at 50% and ejects the CD-ROM but the message in PowerISO software is "completed". That is strange. Maybe this file "cd140201.iso" is corrupted or not complete.
Can you confirm that when you uncompress this ISO file, you get the same file contents?
0
Adam LeinssServer SpecialistCommented:
Hyper-V-Manager-2014-11-18-07-49-30.jpg  Works fine for me?
0
sgleeAuthor Commented:
That is exactly what I get. So I created a bootable CD correctly then.
What do you do next?
0
Adam LeinssServer SpecialistCommented:
Hit the enter key to boot the disc
0
sgleeAuthor Commented:
That is when I get an error repeatedly. I will get the screenshot and post it.
My new Win7 PC is almost done.
0
Adam LeinssServer SpecialistCommented:
Wow, you are right...try this one:

http://pogostick.net/~pnh/ntpasswd/cd110511.zip

Surprised no one reported that to the author yet...
0
sgleeAuthor Commented:
@Adam,
 
 I was able to "enable" administrator's account and "reset" the password for the account.
 I also able to clear the password that I set for "User" account that I created during Win7 Setup process.
 The only thing that I did not see is "assigning a password" to the accounts.
0
Adam LeinssServer SpecialistCommented:
Oh, just login and set a password from the full OS then.
0
sgleeAuthor Commented:
@Adam,

  Thank you for your help and I appreciate it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.