Solved

MAILTO: link not working in IE 11

Posted on 2014-11-17
9
2,511 Views
Last Modified: 2014-11-18
When clicking on a standard mailto: tag in Internet Explorer 11, it just copies the link to the address bar and displays a Page Cannot be displayed message. The same link works fine in Safari and Chrome.

The html is: <a href="mailto:test@test.com">click me</a>

I have verified that Outlook is the default program for MAILTO links
0
Comment
Question by:BrianFord
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 58

Expert Comment

by:Gary
ID: 40448906
Check your internet settings, they may be set too high
Tools/Internet Options -> Security
0
 

Author Comment

by:BrianFord
ID: 40448911
Thanks for the suggestion, tried it, didn't make any difference :(
0
 
LVL 58

Expert Comment

by:Gary
ID: 40448917
Are you sure this is just a plain ol' mailto link and no js intervention?
Do you have a link to the offending page?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:BrianFord
ID: 40448943
Yes I'm sure, I wrote it :) it's definitely a plain mailto link as per the code above.
Sorry I don't have a link to it as it's not published at this point. The link works fine in the other browsers, just not in IE
0
 
LVL 58

Expert Comment

by:Gary
ID: 40449032
Can you save the page as complete and attach here.
Otherwise I have no idea
0
 

Author Comment

by:BrianFord
ID: 40449458
I have created a test page with nothing on it but a simple label and mail link (see attached) and I still get the same issue, pretty convinced this is an issue with IE and not the html
C--Projects-AppleHill-mailTest.html
0
 
LVL 58

Accepted Solution

by:
Gary earned 500 total points
ID: 40449990
Try with IE in safe mode
Run
iexplore -extoff
0
 

Author Comment

by:BrianFord
ID: 40450959
Thanks Gary,

I tried that and the worked correctly, I guess I now need to find out which add-on is causing the issue
0
 

Author Closing Comment

by:BrianFord
ID: 40450995
Thanks Gary,

I found the offending add-on, once I disabled it everything works as it should.

For anyone else with this issue the Add-On was "Wondershare Video Converter'
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In threads here at EE, each comment has a unique Identifier (ID). It is easy to get the full path for an ID via the right-click context menu. However, we often want to post a short link within a thread rather than the full link. This article shows a…
Originally, this post was published on Monitis Blog, you can check it here . Websites are getting bigger and more complicated by the day. Video, images and custom fonts are all great for showcasing your product or service. But the price to pay in…
In this tutorial viewers will learn how to embed videos in a webpage using HTML5. Ensure your DOCTYPE declaration is set to HTML5: "<!DOCTYPE html>": Use the <video> tag to insert a video. Define the src as the URL of your video; this is similar to …
The viewer will learn the basics of jQuery including how to code hide show and toggles. Reference your jQuery libraries: (CODE) Include your new external js/jQuery file: (CODE) Write your first lines of code to setup your site for jQuery…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question