MAILTO: link not working in IE 11

When clicking on a standard mailto: tag in Internet Explorer 11, it just copies the link to the address bar and displays a Page Cannot be displayed message. The same link works fine in Safari and Chrome.

The html is: <a href="mailto:test@test.com">click me</a>

I have verified that Outlook is the default program for MAILTO links
BrianFordAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

GaryCommented:
Check your internet settings, they may be set too high
Tools/Internet Options -> Security
0
BrianFordAuthor Commented:
Thanks for the suggestion, tried it, didn't make any difference :(
0
GaryCommented:
Are you sure this is just a plain ol' mailto link and no js intervention?
Do you have a link to the offending page?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

BrianFordAuthor Commented:
Yes I'm sure, I wrote it :) it's definitely a plain mailto link as per the code above.
Sorry I don't have a link to it as it's not published at this point. The link works fine in the other browsers, just not in IE
0
GaryCommented:
Can you save the page as complete and attach here.
Otherwise I have no idea
0
BrianFordAuthor Commented:
I have created a test page with nothing on it but a simple label and mail link (see attached) and I still get the same issue, pretty convinced this is an issue with IE and not the html
C--Projects-AppleHill-mailTest.html
0
GaryCommented:
Try with IE in safe mode
Run
iexplore -extoff
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BrianFordAuthor Commented:
Thanks Gary,

I tried that and the worked correctly, I guess I now need to find out which add-on is causing the issue
0
BrianFordAuthor Commented:
Thanks Gary,

I found the offending add-on, once I disabled it everything works as it should.

For anyone else with this issue the Add-On was "Wondershare Video Converter'
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
HTML

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.