Solved

Sharepoint 2010 Restore

Posted on 2014-11-18
2
560 Views
Last Modified: 2014-12-03
Dear Experts,

I had to rebuild SP from scratch and restore it from a full farm backup.  Everything seems to go well, except that the restore completed with 14 errors and a bunch of warnings.  The errors are below.  What do I missed and how to correct them, please advise.

Object StateService_####series-of-numbers failed in event OnRestore. For more information, see the spbackup.log or sprestore.log file located in the backup directory. SqlException: The operation did not proceed far enough to allow RESTART. Reissue the statement without the RESTART qualifier. RESTORE DATABASE is terminating abnormally.

Object WSS_Content failed in event OnRestore. For more information, see the spbackup.log or sprestore.log file located in the backup directory. SqlException: The operation did not proceed far enough to allow RESTART. Reissue the statement without the RESTART qualifier. RESTORE DATABASE is terminating abnormally.

Object WSS_Search_servername_####series-of-number (previous name: WSS_Search_servername_####series-of-numbers) failed in event OnRestore. For more information, see the spbackup.log or sprestore.log file located in the backup directory. SqlException: The operation did not proceed far enough to allow RESTART. Reissue the statement without the RESTART qualifier. RESTORE DATABASE is terminating abnormally.

Object SharedServices1_Taxonomy failed in event OnPostRestore. For more information, see the spbackup.log or sprestore.log file located in the backup directory. InvalidCastException: Unable to cast object of type 'Microsoft.SharePoint.Taxonomy.MetadataWebServiceApplication' to type 'Microsoft.SharePoint.Administration.SPDatabaseServiceInstance'.

and so on. Thanks.
0
Comment
Question by:swgit
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 15

Accepted Solution

by:
colly92002 earned 500 total points
ID: 40452039
It looks like some of the databases  did not restore.  It's possible that If they did not restore it won't work as expected.  
Check using SQL Server Manager to see if they are available, and also check the more detailed log files (spbackup.log or sprestore.log) to get more detail of what failed.
1
 
LVL 1

Author Closing Comment

by:swgit
ID: 40479117
Sorry it took me too long to reply to this... still working on it... but all service packs, updates have to match... half way there... some sites work, some still have errors related to dependencies...  Thanks.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Note:  There are two main ways to deploy InfoPath forms:  Server-side and directly through the SharePoint site.  Deploying a server-side InfoPath form means the form is approved by the Administrator, thus allowing greater functionality in the form. …
When installing SharePoint 2010 RTM I came across a strange error, I was getting timeouts during the installation. I searched the web and found the best solution to be found here (http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010genera…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question