Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 474
  • Last Modified:

Exchange 2010 DNSConnectorDelivery Retry

We have an Exchange 2010 server that all of a sudden started going into a Retry status on DNSConnectorDelivery. I can stop and restart the Transport service and it will send mail out for a few minutes and then stop again. Inbound email works fine as does internal email. only outbound appears to be affected.
0
350ztn
Asked:
350ztn
  • 8
  • 6
1 Solution
 
tshearonCommented:
Do you send mail to the internet using MX records or through a smart host?
0
 
350ztnAuthor Commented:
sending through MX.

Also another bit of info I just discovered. I did an Nslookup on the server and it does not resolve google.com. it is using IPv6. so I disabled the IPv6 and ran the nslookup and it was successful.
I restarted the Transport service and it would not start with IPV6 disabled?
0
 
tshearonCommented:
Don't disable it. You need it for the service to start. Just simply unselect it on the properties of the network adapter you are using.
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 
350ztnAuthor Commented:
Sorry- that is what I meant. I unchecked it on the adapter properties. but transport service will not start with it unchecked.
0
 
tshearonCommented:
hrmm. You can disable it in the registry and it should still start. Try this:

http://busbar.blogspot.com/2010/05/unable-to-moun-exchange-2010-db.html
0
 
350ztnAuthor Commented:
I did this...

Open Registry Editor.
Locate the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters
In the details pane, click New, and then click DWORD (32-bit) Value.
Type DisabledComponents, and then press ENTER.
Double-click DisabledComponents, and then type 0xffffffff in Hexadecimal or 4294967295 in Decimal.

Transport Starts, but nslookup is still using IPv6 and not resolving.
0
 
tshearonCommented:
Sorry, wrong link. Here is the link to what I should have sent.

http://technet.microsoft.com/en-us/network/cc987595.aspx

What happens if you uncheck it now? Does it work? Have you restarted the server after making registry change?
0
 
350ztnAuthor Commented:
I did not restart server or uncheck it... I will try both and report back
0
 
350ztnAuthor Commented:
removed the check mark from IPV6 and rebooted. mail is currently sending after the reboot. After the reboot I stopped and started transport and it was successful. nslookup resolves correctly now.

I will give it 30 minutes and test email sending to see if it still works.
0
 
tshearonCommented:
Glad to hear. Let me know how it goes.
0
 
350ztnAuthor Commented:
still not working.
0
 
350ztnAuthor Commented:
I checked dns and flushed the cache and the send connectors. all looked. ipconfig flushdns and registerdns.
that started sending mail. i did not stop and start transport service. hoping this fixed it
0
 
tshearonCommented:
Flushing and registering DNS should have no effect since after restarting there were no changes made that would affect DNS config or cache.
0
 
350ztnAuthor Commented:
It's still working. I can only assume the DNS flush or register did it. Thank you for the assistance.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 8
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now