Exchange 2010 DNSConnectorDelivery Retry

We have an Exchange 2010 server that all of a sudden started going into a Retry status on DNSConnectorDelivery. I can stop and restart the Transport service and it will send mail out for a few minutes and then stop again. Inbound email works fine as does internal email. only outbound appears to be affected.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Do you send mail to the internet using MX records or through a smart host?
350ztnAuthor Commented:
sending through MX.

Also another bit of info I just discovered. I did an Nslookup on the server and it does not resolve it is using IPv6. so I disabled the IPv6 and ran the nslookup and it was successful.
I restarted the Transport service and it would not start with IPV6 disabled?
Don't disable it. You need it for the service to start. Just simply unselect it on the properties of the network adapter you are using.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

350ztnAuthor Commented:
Sorry- that is what I meant. I unchecked it on the adapter properties. but transport service will not start with it unchecked.
hrmm. You can disable it in the registry and it should still start. Try this:
350ztnAuthor Commented:
I did this...

Open Registry Editor.
Locate the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters
In the details pane, click New, and then click DWORD (32-bit) Value.
Type DisabledComponents, and then press ENTER.
Double-click DisabledComponents, and then type 0xffffffff in Hexadecimal or 4294967295 in Decimal.

Transport Starts, but nslookup is still using IPv6 and not resolving.
Sorry, wrong link. Here is the link to what I should have sent.

What happens if you uncheck it now? Does it work? Have you restarted the server after making registry change?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
350ztnAuthor Commented:
I did not restart server or uncheck it... I will try both and report back
350ztnAuthor Commented:
removed the check mark from IPV6 and rebooted. mail is currently sending after the reboot. After the reboot I stopped and started transport and it was successful. nslookup resolves correctly now.

I will give it 30 minutes and test email sending to see if it still works.
Glad to hear. Let me know how it goes.
350ztnAuthor Commented:
still not working.
350ztnAuthor Commented:
I checked dns and flushed the cache and the send connectors. all looked. ipconfig flushdns and registerdns.
that started sending mail. i did not stop and start transport service. hoping this fixed it
Flushing and registering DNS should have no effect since after restarting there were no changes made that would affect DNS config or cache.
350ztnAuthor Commented:
It's still working. I can only assume the DNS flush or register did it. Thank you for the assistance.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.