Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange mailbox moving problem

Posted on 2014-11-19
7
Medium Priority
?
767 Views
Last Modified: 2016-06-15
Hello experts,

We have Exchange 2010 SP3 with four databases. One mailbox only is having the below issue:

When any user sends an email to this mailbox, he receives this bounce message:


#554 5.2.0 STOREDRV.Deliver.Exception:ObjectNotFoundException.MapiExceptionNotFound; Failed to process message due to a permanent exception with message Cannot get ID from name. 16.55847:7B000000, 17.43559:000000000E010000000000000000000000000000, 255.23226:2B0A0000, 255.27962:02000000, 255.17082:0F010480, 0.21857:80030400, 4.21921:0F010480, 255.27962:FA000000, 255.1494:00000000, 255.26426:02000000, 0.21097:EC030000, 1.39027:EE920D00, 4.8756:BFF9FFFF, 0.58685:1DFAFFFF, 1.63603:EE920D00, 4.50493:0F010480, 0.49161:EC030000, 4.6719:0F010480, 4.7007:0F010480, 0.48671:EC030000, 255.1750:00000000, 255.27962:56000000, 255.17082:B9040000, 0.16993:00000000, 4.21921:B9040000, 255.27962:FA000000, 255.1494:6A1C0000, 255.26426:56000000, 255.1750:0211D836, 0.26849:00000000, 255.21817:B9040000, 0.37224:B9040000, 4.40808:0F010480, 0.24529:0F010480, 4.18385:0F010480 ##

I tried to move this mailbox from a DB to another in order to try solving this issue, but I am receiving the below error upon move request:

Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:00


Failed

Error:
MapiExceptionNotFound: Unable to get properties on object. (hr=0x8004010f, ec=-2147221233)
Diagnostic context:
    Lid: 55847   EMSMDBPOOL.EcPoolSessionDoRpc called [length=72]
    Lid: 43559   EMSMDBPOOL.EcPoolSessionDoRpc returned [ec=0x0][length=278][latency=0]
    Lid: 23226   --- ROP Parse Start ---
    Lid: 27962   ROP: ropOpenFolder [2]
    Lid: 17082   ROP Error: 0x8004010F
    Lid: 21857  
    Lid: 21921   StoreEc: 0x8004010F
    Lid: 27962   ROP: ropExtendedError [250]
    Lid: 1494    ---- Remote Context Beg ----
    Lid: 26426   ROP: ropOpenFolder [2]
    Lid: 21097  
    Lid: 39027   dwParam: 0xD92EE
    Lid: 8756    StoreEc: 0xFFFFF9BF
    Lid: 58685  
    Lid: 63603   dwParam: 0xD92EE
    Lid: 50493   StoreEc: 0x8004010F
    Lid: 49161  
    Lid: 6719    StoreEc: 0x8004010F
    Lid: 7007    StoreEc: 0x8004010F
    Lid: 48671  
    Lid: 1750    ---- Remote Context End ----
    Lid: 27962   ROP: ropGetPropsSpecific [7]
    Lid: 17082   ROP Error: 0x4B9    
    Lid: 26465  
    Lid: 21921   StoreEc: 0x4B9    
    Lid: 27962   ROP: ropExtendedError [250]
    Lid: 1494    ---- Remote Context Beg ----
    Lid: 26426   ROP: ropGetPropsSpecific [7]
    Lid: 36739  
    Lid: 1750    ---- Remote Context End ----
    Lid: 26849  
    Lid: 21817   ROP Failure: 0x4B9    
    Lid: 20385  
    Lid: 28577   StoreEc: 0x8004010F
    Lid: 32001  
    Lid: 29953   StoreEc: 0x8004010F

Exchange Management Shell command attempted:
'ourdomain.com/Users/XYZ' | New-MoveRequest -TargetDatabase 'newDB' -BadItemLimit '0'

Elapsed Time: 00:00:00

Any help solving this?
0
Comment
Question by:Muhajreen
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
7 Comments
 
LVL 16

Expert Comment

by:Rajitha Chimmani
ID: 40453549
Try to disconnect the mailbox and reconnect it again. But be cautious to take a backup of all attributes by running Get-Mailbox | fl before disconnecting. When you disconnect a mailbox all Exchange attributes will be reset. Try running New-

I would even recommend to get rid of the mailbox as it appears to be corrupted. Try running New-MailboxRepairRequest to see if the corruption can be dealt with. If not then

1. Run Get-Mailbox username | fl
2. Make a note of the legacyExchangeDN
3. Export all contents to a PST.
4. Disconnect the mailbox.
5. Create a new mailbox with same Alias and displayname
6. Update all the Exchange attributes from Step 1
7. Add legacyExchangeDN as X500 address
8. Import the contents from PST to the new mailbox.
0
 

Author Comment

by:Muhajreen
ID: 40453571
Thank you.

Still the very same problems after disabling and re-connecting the mailbox again.
0
 
LVL 16

Expert Comment

by:Rajitha Chimmani
ID: 40453582
Then, you may have to run the repair or create a new mailbox as suggested in my last post.

Another option is to restore the DB but I would prefer creating a new mailbox if you can export the contents to a PST.
0
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 31

Accepted Solution

by:
Gareth Gudger earned 2000 total points
ID: 40454185
If the repair request did not help and you can't move it then I would try and Export all data to a PST. Delete the mailbox completely. Create a new mailbox (maybe in a new database) and import all the data back in.

One other inkling I am getting from all this is that there may be something wrong with the User account itself.
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40454189
This is an interesting take on it. But got me thinking that it could be corruption with one of the default folders in Outlook.
http://terenceluk.blogspot.com/2014/02/exchange-2007-to-2010-mailbox-move.html

Anything displaying weird default folder wise when you log into the mailbox?
0
 

Author Comment

by:Muhajreen
ID: 40458930
Thank you.

Finally, as advised above, I requested my assistant to move all messages through Outlook to a pst, after which I can delete and re-create the mailbox.

I am unable to export any mailbox directly from Exchange server to a pst due to a know issue which I faced many times few months ago (maybe has be solved by Microsoft now).
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New style of hardware planning for Microsoft Exchange server.
How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question