Solved

how to open specific ports on my ASA 5505

Posted on 2014-11-19
8
189 Views
Last Modified: 2014-11-21
Hi,

Can someone tell me the process I need to open two ports on my firewall.
At present I'm running a cisco asa5505 firewall but I'm a little unsure how to open
both 18601 & 18603 ports on the firewall.
I can connect through ASDM v6.2 for the GUI interface as I'm not a fully conversant in CLI mode although I can use it if I have to.

I have included my running config which is very basic.
Hope this helps

_________________
ASA Version 8.2(1)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.3.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 192.168.1.2 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
access-list Controller_in extended permit tcp any interface outside eq www
access-list Controller_In extended permit tcp any interface outside eq www
pager lines 24
logging buffered debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface www 192.168.3.140 www netmask 255.255.255.255
access-group Controller_In in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.3.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.3.5-192.168.3.36 inside
dhcpd dns 208.67.220.220 208.67.222.222 interface inside
dhcpd lease 28800 interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:7085fe54a1d2e5361a5dc22ab33a3a73
: end
no asdm history enable
________________________

Thanks
0
Comment
Question by:cannonz
  • 4
  • 4
8 Comments
 
LVL 24

Expert Comment

by:Ken Boone
ID: 40453381
What devices need to be access on these ports?
0
 

Author Comment

by:cannonz
ID: 40453402
Hi,

Basically I've downloaded an app from iTunes that gives me access to my flight management computer in MS FSX on my ipad rather than clicking it with my mouse on my PC which only works locally as far as I'm aware so I only need to open these ports internally (I think).
0
 
LVL 24

Expert Comment

by:Ken Boone
ID: 40453420
So let me make sure I understand where things are...  the flight mgmt computer is on the inside of the firewall, and the iPad is on the outside?  The iPad needs to reach the flight mgmt computer on those two ports from the outside of the firewall? Is that right?
0
 

Author Comment

by:cannonz
ID: 40453453
Yes the FMC is on the internal network if that's what you mean and the ipad is on my internal network (same one as my pc)
If I go to www.yougetsignal.com and ping either of these ports on my ipad it says ports are closed on my external ip.
Is this what you mean.?
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 24

Expert Comment

by:Ken Boone
ID: 40453581
So if all of the devices are on the inside of your network and they need to talk to each other on these ports, then the firewall has no play here.  It is not involved.    If all devices are on the inside, there will not need to be an opening in the firewall for something on the outside to reach these devices.  Does that make sense?
0
 

Author Comment

by:cannonz
ID: 40453746
Is it possible that maybe it does need to connect to a central server online or something
Even though I would be using the app locally?
I will double check my PC tomorrow incase it's an issue with that end but I think that's  doubtful as my iPad can't even see these ports opened.
0
 
LVL 24

Accepted Solution

by:
Ken Boone earned 500 total points
ID: 40454042
So if it needs to connect to something on the outside your firewall is already allowing all outbound traffic without any blocking.
0
 

Author Comment

by:cannonz
ID: 40457041
After some more fault finding It appears that even though I have the downloaded software and paid for ipad app one program I use in the background on FSX needs to be registered as I only have a demo some programs won't work unless registered so I will have to register fsuip you would think it would at least flag this info up on the screen.
only found this out with a bit of research.

Thanks again for you help
0

Featured Post

New! My Passport Wireless Pro Wi-Fi Mobile Storage

Portable wireless storage to offload, edit, and stream anywhere.

High-capacity, wireless mobile storage designed to accompany professional photographers and videographers in the field to easily offload, edit and stream captured photos and high-definition videos.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article you will get to know about pros and cons of storage drives HDD, SSD and SSHD.
A clone is a duplicate copy. Sheep have been cloned and maybe someday even people will be cloned, but disk cloning (performed by the hard drive cloning software) is a vital tool used to manage and protect data. Let’s look at what hard drive cloning …
This tutorial gives a high-level tour of the interface of Marketo (a marketing automation tool to help businesses track and engage prospective customers and drive them to purchase). You will see the main areas including Marketing Activities, Design …
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

28 Experts available now in Live!

Get 1:1 Help Now