• Status: Solved
  • Priority: Medium
  • Security: Private
  • Views: 56
  • Last Modified:

"Task Scheduler service is not available. Task Scheduler will attempt to reconnect to it."

I'm getting this error "Task Scheduler service is not available. Task Scheduler will attempt to reconnect to it."  while trying to create a very simple task.  
I've read a handful or articles online already including the ones about changing the registry, and so far no luck with anything suggested there.  Not sure what else to do, but I am running out of options.  This started as an SSIS job that throws an access is denied error no matter what.  So a scheduled task to run a batch file to move files should be a decent alternative, except that I can't build my task to go get my files for processing.  Please help!!
0
GingerKitty
Asked:
GingerKitty
  • 4
  • 2
1 Solution
 
Koen Van WielinkIT ConsultantCommented:
Ok, this is probably a very obvious question but I have to ask it anyway. Have you checked the windows services to see what's going on with the task scheduler service? Is it turned off? What happens when you manually try to start it?
0
 
GingerKittyAuthor Commented:
Hi Koen,
Yes, I checked that first; the service is running, and under properties it is set to run the service automatically, and also keep trying to restart if it fails.  I did the stop and manually restart as well just to make sure, but I still get the same error even though the service is running.
0
 
GingerKittyAuthor Commented:
One thing that might be causing me grief with my batch file is that the task scheduler runs as local system, and maybe it needs to run as sysadmin since sysadmin has rights to the location where I have to move the file from?  I went to change the user the service runs as, and everything is grayed out.  How can I change that user?
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
Koen Van WielinkIT ConsultantCommented:
Hi Ginger,

I thought I posted that exact question but apparently I screwed that one up :p.
Anyway, I had a look at our own environment where we have a bunch of scheduled tasks and it seems you're indeed not supposed to change the user account of the task scheduler. Did you also happen to check under the dependencies whether all the services on which the task scheduler is dependent are running properly?
Another thing to check, what are the security rights on the folder which you're trying to manipulate? During your testing phase, I would make sure the full control has been given to "Everyone". If that solves the issue you know where to look. If not, you know it's not a folder or file rights issue.
0
 
GingerKittyAuthor Commented:
Hi Koen,
Yep, I also checked all the dependency services to make sure they were all enabled and running.  We are good there too.
Unfortunately myself and the network admin checked that the security was sufficient, and he made everything this process needs to get into wide open to help me get it working.  So that wasn't it either.  I pretty much gave up and wrote a handful of batch processes and scheduled them in the SQL agent in the order I needed them to run so I could bypass the things that were giving me issues.  Clunky, but it does work.  Thanks!
0
 
GingerKittyAuthor Commented:
it isn't exactly how I wanted my process to run, but it gets the job done.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now