Remote Desktop Easy Print does not work

Honored Experts.

I have a Server 2012R2 with the Remote Desktop Services role installed.
I have just set up a new users remote PC in a branch office connecting via WAN.

This user is running Windows 7 SP1 with a Brother laser printer connected via USB.

The problem is, that this user is not able to print from the sessions when connected to the remote desktop server.
I can confirm that the remote session sees hes printer as "Brother HL series (Redirected2)" but even with a test job nothing comes out on the printer.
There are no error messages what so ever!

Any ideas?
OhmitAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Yes, it does _NOT_ work. Period. End of sentence. Full stop. :(

We disable EasyPrint via GPO for both the RDS servers (Machine based GPO) and RD Users (User based GPO).

Universal drivers for HP and Lexmark are used in Isolated Mode (Print Management) on the RDSH servers.

Any other form of print driver must also be in Isolated Mode to allow things to print relatively stable.

Avoid Host-based printers (no PCL engine built-in like the 1000 series HP) as their drivers do _not_ work in a RDS setup.
0
OhmitAuthor Commented:
Ok sounds Strange and Im not sure i understand. Is it possible to reenable with gpo?

The printer is a brand new Brother mono laserprinter  I dont recall the model but its a smaller model.
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
RD EasyPrint does not work. We've had nothing but grief trying to make it work and gave up in 2008 RTM/R2.

Use the printer's Universal Print Driver on the RDSH. In the Print Management console under drivers set any driver listed there for physical or virtual (Adobe PDF, OneNote, ETC) printers to Isolated Mode.

Make sure the same Universal Print Driver is installed on any remotely connecting endpoints so there are no breakdowns due to driver differences.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

OhmitAuthor Commented:
Ok.
What is the RDSH and where do I find the Print Management console?
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
RDSH = Remote Desktop Session Host (the server)

Print Management Console is a part of the Feature RSAT (Remote Server Administration Tools). Install it using the Add/Remove Role/Feature wizard. We install it on all RDSH servers.
0
OhmitAuthor Commented:
Hello Philip.
I really appreciate your inputs :-)

Im not quite sure here.
Are you telling me, that this is never going to work, or just that I need additional steps?
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Easy Print does not work.

A proper print driver setup on RDS and the remote client does.
0
OhmitAuthor Commented:
Could you please explain how I does this?

Right now I have changed gpo not to chose easy print as first option and i have installed a printer driver in the server. When i print everything looks fine except that i dont get any print jobs!
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Download the driver from the manufacturer's web site.
Install the driver using the Print Management Console.
Set the driver to isolated mode.

Download the same driver and install on the remotely connecting system.

Connect to the RDSH. User should get Printer (Redirected #) in their Printers and Devices list.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
OhmitAuthor Commented:
Where exactly do I change to "Isolated mode"? :-)
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
In Print Management --> Print Servers --> SERVER --> Drivers --> Right Click on the driver --> Set Driver Isolation --> Isolated.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.