Link to home
Create AccountLog in
Avatar of jbla9028
jbla9028Flag for United States of America

asked on

Cisco Catalyst switch - Keep VLAN UP

I have a Cisco 3750X switch. I am configuring layer 3 SVIs and I do not have access to the device to physically connect devices. I want to put the devices in UP/UP state. I beleive there's a way to do this with VLAN State active or some other command. Does anyone know the configuration needed so I can fully configure and test ping on SVIs?
Avatar of Predrag Jovic
Predrag Jovic
Flag of Poland image

This should work.
Add interface to your VLANs and under interface issue no keepalive. Port should come up, so VLAN too.
have you tried putting the one of the physical interfaces of that vlan into loopback mode?
Avatar of jbla9028

ASKER

I have not. how do I do that?
take an rj45 loop connector and plug it into the interface.

the pinouts should be 1 to 3 and 2 to 6.
Jan, thank you but I do not have physical access to the device for a few weeks. I thought there was another way that could be done via CLI to set the SVI into UP/UP.  on a router its called no autostate. That command however is only available on Cisco routers.



http://packetlife.net/blog/2009/nov/9/svi-autostate/
some router interfaces can be soft forced into loopback but i don't see where the 3750 interfaces can do this.
Did you tried to add VLAN to trunk (and check is really VLAN created, just in case, I know it should, but...)?
switchport trunk allowed vlan add xx

If SVI exist on switch, you should add 1 port to forwarding state and adding VLAN to trunk could do that.
I just checked, it worked in GNS3, but on a real switch, who knows. :)
at least one physical interface passing that vlan has to be up/up before the vlan can come up/up.
Is there anything connected to switch? Or there's no nothing at all attached to switch, not on a single port?
you can't have just any port.  the switch has to have a vlan connected port in up/up or that vlan being passed and recognized across a trunked interface for the vlan interface to be up/up.
Yes that's right (I forget that I have already did something on config - my suggestion don't work), but how author is connected to switch? Out of band?
yes and a software loop doesn't appear to be an option.
I am currently connected to the switch via the console port. No cables are connected to interfaces. It not a critical issue so I will be able to eventually hook up the interface and set interface to trunk all traffic to test. I just figured there had to be some way. It looks like on 4500 switches it works.
ASKER CERTIFIED SOLUTION
Avatar of Jan Bacher
Jan Bacher
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
@aleghart - that's correct, although the switch is already reachable remotely via IP so I don't imagine the requirement is simply to telnet/SSH to the switch using a different IP.
Sometimes, you remove the IP that's in the user LAN, and use only a management VLAN for access.  Makes it easy to limit access to the management interfaces, and helps lock down in a WAN environment where many subnets are routed to other sites.

Site A user LAN subnet can see Site B's user LAN subnet, but not the management subnet.
I know that, but access to switch via WAN is up obviously so no management access via user LAN is in effect at the moment.
unfortunately none of these worked. I ended up getting interfaces setup and the IPs came up. Thank you for the help though.
You should ask for the question to be deleted then, instead of picking an incorrect answer.