Solved

How to install I/E adm file into a group policy on a domain controller

Posted on 2014-11-20
15
153 Views
Last Modified: 2014-11-25
I need to setup a group policy with an I/E adm for server 2008 r2. I have the file downloaded but I dont know where to add this into the group policy?
0
Comment
Question by:vmich
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 4
  • 3
15 Comments
 
LVL 1

Expert Comment

by:PotterJon
ID: 40455305
0
 
LVL 1

Expert Comment

by:PotterJon
ID: 40455321
Works the same for Server 2008, although ADMX files can now be imported.
0
 
LVL 21

Expert Comment

by:Radhakrishnan R
ID: 40455338
Hi,

If you have ADMX files then the same method won't apply. You will need to follow the below steps

Locate C:\Windows\PolicyDefinitions>>Place the admx files here, now go to en-US folder and place the .adml file there.

Go to start>>run>>gpmc>>open the appropriate policy, the newly added policy will be listed now.
0
How our DevOps Teams Maximize Uptime

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us. Read the use case whitepaper.

 
LVL 1

Author Comment

by:vmich
ID: 40455359
I have the file for I/E 10 and it is a adm file..
Does the same apply for the install
0
 
LVL 21

Expert Comment

by:Radhakrishnan R
ID: 40455424
Hi,

If it is ADM file then you can just add it from policy>>Administrative Templates>>Add/Remove Templates>>Select the location where you have saved (I would personally suggest to copy the adm file to C:\Windows\inf) and add it accordingly.

But it's good if you could add admx files as the 2008 based servers use ADMX templates rather than adm. If you are interested then go ahead and download the file from below link and follow the procedure from my earlier update.
http://www.microsoft.com/en-in/download/details.aspx?id=40905
0
 
LVL 1

Author Comment

by:vmich
ID: 40455430
I cant copy  the new file to the folder c:\windows\policypackage\en-us because it keeps telling me I dont have permissions when I am logged in as the domain administrator.
How do i get around this?
0
 
LVL 1

Expert Comment

by:PotterJon
ID: 40455431
As menitoned by Radhakrishnan Rajayyan, ADMX files will give you more options to restrict IE.
0
 
LVL 1

Author Comment

by:vmich
ID: 40455447
I am using the admx files but cant copy the adml file to the en-us folder. It keeps saying I dont have permissions.
0
 
LVL 21

Expert Comment

by:Radhakrishnan R
ID: 40455458
Could you make sure the location is same as C:\Windows\PolicyDefinitions\en-US. As per your update it says "policypackage". I don't think there is such folder in 2008 server.

Also, make sure the security permissions are correct.
0
 
LVL 1

Author Comment

by:vmich
ID: 40455473
That was a typo by me.. That is where the folder is and the permissions are correct. I even took ownership of the file but that did not work either..
0
 
LVL 1

Author Comment

by:vmich
ID: 40455509
Ok I got the files in there but now I dont see where it should be showing up in the GPO.
I am editing the default domain policy because this is where we want to apply it.
Can you help?
0
 
LVL 21

Expert Comment

by:Radhakrishnan R
ID: 40455524
Hi,

Glad to know that you have added the files. Go to gpmc>>Right click and edit default domain policy>>Expand "User Configuration">>Policies>>Administrative Templates>>Windows components>>It should be there "Internet Explorer" or similar to that.
0
 
LVL 1

Author Comment

by:vmich
ID: 40455609
I see it there but I need it to show up under user\preferences\control panel\internet settings and then right click, not user\policies.
Because  this is where now there are setting for i/e 5,6,7,and 8 but not 9 or 10 which we need 10
0
 
LVL 1

Accepted Solution

by:
vmich earned 0 total points
ID: 40456037
I solved the issue by adding some registry entries in to allow the proxy settings to be avaialble since you cannot do this via the preference with I/E 10 or 11..
This is the settings I had to add to the registry..
ProxyEnable"=dword:00000001
ProxyServer"="10.1.1.12:8080"
ProxyOverride"="http://*.internal.lan;https://*.internal.com;<local
0
 
LVL 1

Author Closing Comment

by:vmich
ID: 40464148
registry
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Last week, our Skyport webinar on “How to secure your Active Directory” (https://www.experts-exchange.com/videos/5810/Webinar-Is-Your-Active-Directory-as-Secure-as-You-Think.html?cid=Gene_Skyport) provided 218 attendees with a step-by-step guide for…
A company’s centralized system that manages user data, security, and distributed resources is often a focus of criminal attention. Active Directory (AD) is no exception. In truth, it’s even more likely to be targeted due to the number of companies …
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question