Solved

outlook certificate error  and autodiscover.domain.com

Posted on 2014-11-21
6
567 Views
Last Modified: 2014-11-24
On our Exchange 2010 server we have an SSL certificate for Outlook Anywhere and OWA. This works well but since we have installed the certificate Domain connected users get a certificate error when they open outlook, they just accept and can work normally.
Looking at the certificate name it is for https://domain.com.
There are several articles on the web: Microsoft 940726 and a blog by Elan Shudnow which describe this exact error.
It seems that the certificate needs to have autodiscover.domain.com added as an SNA, would this be added to my Exchange certificate or does my domain hosting company have to add it to there certificate?
0
Comment
Question by:PHBSupport
6 Comments
 
LVL 16

Expert Comment

by:Rajitha Chimmani
ID: 40457499
You need to have autodicover.domain.com added to the Exchange certificate.
0
 
LVL 8

Expert Comment

by:tshearon
ID: 40457705
If you don't currently have it you will need a new one from your provider.
0
 

Author Comment

by:PHBSupport
ID: 40457737
At the moment the certificate is for remote.domain.com
I've reconfigured Exchange to use FQDN as per MS id 940726
I've added autodiscover.domain.com as a SAN to the Exchange certificate

When ever a domain connected user opens Outlook they get a certificate error, it's going to the https certificate of our web site. The hosting company say there nothing they can do as they use a wild card so cant add individual entry's to it

In the "old days" we just put the domain.local in the certificate but that has now been stopped.
0
Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 31

Accepted Solution

by:
Gareth Gudger earned 500 total points
ID: 40458607
There are one of two things you can do.

Either create an autodiscover SRV record at your external DNS provider. That was you can just do a standard SSL. No SAN needed.

The alternative is to an SAN cert.

Check out my article here. I think it will help.
http://supertekboy.com/2014/05/27/designing-a-simple-name-space-for-exchange-2010/
0
 

Author Closing Comment

by:PHBSupport
ID: 40462827
Gareth I had implemented everything in your article except the split brain DNS. Once I had added the entry no more cert errors

Many thanks

And thanks for the other contributions
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40462829
Awesome!
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Utilizing an array to gracefully append to a list of EmailAddresses
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
how to add IIS SMTP to handle application/Scanner relays into office 365.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

803 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question