Exchange mailbox store not visible following a change of permissions

Hi I was trying to export mailboxes from exchange server Version: 6.5.7226.0 on sbs 2003. Exmerge logged an error which suggested that the admin account on the server did not have full read write access to the mailboxes. I right clicked on the mailbox store and chose properties->security and it seem that there were some deny permissions so I went into the advanced and unchecked the inherit permissions tickbox.

I now cannot see the private mailbox store in ESM at all, Is there any way to get this mailbox store remounted?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hypercat (Deb)Commented:
This article lists the minimum required permissions for the mailbox store:

When you unchecked the "inherit permissions" check box, you may have inadvertently removed all permissions from the mailbox store.  In order to restore the permissions, you may have to use ADSIEdit. Have you ever used this tool?
Gareth GudgerSolution ArchitectCommented:
Can you recheck inherited permissions?
GazClimbsAuthor Commented:
Thanks hypercat, no I have not used this tool before, any advice for me?

Gareth, I cannot see the store in ESM so no I cannot edit the permissions
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Gareth GudgerSolution ArchitectCommented:
Unfortunately, I don't have an Exchange 2003 server in front of me anymore and I'm getting old. ;)

Does it give you the security tab at the server level?

As Hypercat mentioned, might have to download and installed ADSI Edit to fix these permissions.
GazClimbsAuthor Commented:
Thanks Gareth,
  That document has no information about using the tool to interact with exchange storage groups, can you direct me towards anything useful?

Hypercat (Deb)Commented:
This article describes where to go in the ADSIEDIT.msc to find the permissions for the Exchange information store.  It specifically describes adding the Exchange server computer to the permissions, but you can add other appropriate permissions in the same way:

The article has you add the permissions at the Server level. Since it seems that you have removed the inheritance from the mailbox store level, what I'd recommend that you do would be to just check the permissions at the server level first.  If they seem normal, check the information store object permissions.  If the info store is inheriting the permissions (as it should be), then drill down further to the specific mailbox store level.  At that point, all you should have to do would be to re-check the "Inherit permissions" box and the correct permissions from the upper level would be applied.
Hypercat (Deb)Commented:
Here's a picture of how it will look in ADSIEDIT.msc.  This is an Exchange 2007 server, so your 2003 will look slightly different, but the basic idea is the same:

ADSIEDIT console showing Exchange objects
I have erased all the domain naming information, so don't be confused by the blank spaces in the picture.
Hypercat (Deb)Commented:
Also, if you're running Exchange 2003 on a Windows 2003 server, you'll have to install the Windows 2003 support tools in order to have adsiedit.msc available.  This tool is included in later OS's, but is an add-on with the Support Tools for Windows 2003.
Hypercat (Deb)Commented:
PPS :-| Another additional instruction:  Once you have adsiedit.msc installed and open, you'll see a blank window with just the adsiedit.msc object.  You need to right-click on ADSI Edit and click "Connect to."  Then in the dialog box, click the down arrow under "Select a well known Naming Context:" and select "Configuration."  This will get you to the correct starting point for getting to the Exchange settings.
GazClimbsAuthor Commented:
I can drill down as far as the first storage group as in the screenshot but when I right click on the mailbox store and choose properties I get the error above,

Any help greatly appreciated, all I need to do is mount this store and exmerge a few gb of mail

Hypercat (Deb)Commented:
Follow the instructions in the first article I posted to make sure that the Exchange server computer is member of the Exchange Domain Servers global group.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
GazClimbsAuthor Commented:
Thanks for you attention in this matter hypercat, I ended up creating a recovery group and accessing the mailboxes in this way, cheers
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.