Solved

Netgear GSM7248 Switch Initial Setup

Posted on 2014-11-21
20
679 Views
Last Modified: 2014-12-01
Hello everyone!

This is driving me crazy.  I've never set this up before, so I am completely lost.

I bought a 48 port switch off of eBay that only had minor damage to the exterior, but was promised fully working.  I got it to replace my 2 24 port 10/100 switches that I have now.

What I'm trying to do is simply assign an IP address to the switch so I can go in and manage it, but I can't seem to figure out how to do this.

From what I have read, I have a serial cable hooked up and I am running Dave's Telnet to emulate a VT100 Terminal, but I can't get a login.  This is where I get lost.  To connect, it asks me for a host name, which I think is supposed to be the IP Address, but I don't have the IP Address, because that's what I'm trying to get to in the first place!  Aggghhh!

I have also tried PuTTY, which seems to get almost connected (I think).  I choose the COM port and it comes up with a green screen cursor, but I hit enter and I can never get to a login screen.

What do I need to do to communicate with this properly?
0
Comment
Question by:Scott Thompson
  • 9
  • 6
  • 5
20 Comments
 
LVL 2

Expert Comment

by:kittuskattus
Comment Utility
You shouldn't need to use the serial cable at all!

Do a factory reset by pressing the reset switch for 2 secs.
This should set it to DHCP assigned address
Plug it into your network (that has a DHCP server)
Login to the switch webconsole using the IP address it has been assigned.

You can find its IP address in the DHCP server's address leases list, or you could do a IP scan on your subnet using Angry IP scanner (or Fing on a Android/IOS device).
0
 
LVL 8

Author Comment

by:Scott Thompson
Comment Utility
I did what you suggested kittuskattus; I cannot find an IP address that was added...
I checked twice on the DHCP lease list.  I also ran FastResolver and cannot find any IP address assigned with the MAC Address of the switch.
0
 
LVL 2

Expert Comment

by:kittuskattus
Comment Utility
Have you tried making an address reservation on the DHCP server for the MAC address of the switch? (assuming that the MAC is printed on a sticker somewhere!)
0
 
LVL 2

Expert Comment

by:kittuskattus
Comment Utility
Just thought - some of the Netgear switches have 2 reset buttons - once you can press with your finger and one that is recessed and you need a paperclip to press. It's the recessed one that does the factory reset.
0
 
LVL 8

Author Comment

by:Scott Thompson
Comment Utility
How do I make the address reservation?  I have a Linksys EA2700 router that I am using.

Also, the reset is in the front and it is recessed.  I used a small screwdriver to reset it.
0
 
LVL 2

Expert Comment

by:kittuskattus
Comment Utility
You can usually tell if the reset has worked by watching the LEDs - they will all change whilst you are holding the button down. Maybe if it doesn't do it after 2 secs, hold it a bit longer!
0
 
LVL 2

Expert Comment

by:kittuskattus
Comment Utility
I don't have access to one right now to check but i think it's in Settings/Basic Settings/DHCP Reservations/Add Client
0
 
LVL 8

Author Comment

by:Scott Thompson
Comment Utility
I found where to put the DHCP reservation.

I put in the MAC address and assigned it 192.168.0.201.  I gave it the client name GSM7248, because I have no idea what it is supposed to be.

I appreciate you working with me on this.  I am heading home at the moment, but it is still not communicating.  I have this computer going through the switch and I'm getting an IP address VIA DHCP just fine...

I tried to connect to 192.168.0.201 and get nothing.

I tried to ping 192.168.0.201 and I get the response "Reply from 192.168.0.110: Destination Host Unreachable"
0
 
LVL 8

Author Comment

by:Scott Thompson
Comment Utility
I guess that's why I was hoping to try to go through the serial connection, because from my understanding that's where I can manually change the IP address for the switch.
0
 
LVL 2

Expert Comment

by:kittuskattus
Comment Utility
Rather than using Putty have you tried using TeraTerm? It was the only program that I could get to set an IP address through the serial port on an APC UPS Network Management Card.

http://ttssh2.sourceforge.jp/index.html.en
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 15

Expert Comment

by:Perarduaadastra
Comment Utility
As it's an eBay special I'm assuming that the switch is a GSM7248v1.

The manual can be found here:

http://www.downloads.netgear.com/files/gsm7212_gsm7224_gsm7248_60015_installguide.pdf

... and explains how to to do the initial configuration. I think PuTTY will be very useful!

Netgear's site also has documentation for the GSM7248v2 model.
0
 
LVL 8

Author Comment

by:Scott Thompson
Comment Utility
Perarduaadastra;

Yes it is a v1 of the switch.  The problem I'm having is trying to communicate using PuTTY.  I've never used it before so this is very unfamiliar to me.  I have downloaded the manual, but following the instructions (as far as I read), I still can't get it to communicate.
0
 
LVL 15

Expert Comment

by:Perarduaadastra
Comment Utility
I have access to a GSM 7224v1 which is probably a very early model; I don't remember the gruesome details of setting it up as it was the best part of two years ago, but I do remember what a mission it was to update the factory release firmware to something a bit more current... Oddly enough, I don't remember console access as being a problem. I'll try and get to it later this evening and hopefully let you know how it's done.
0
 
LVL 8

Author Comment

by:Scott Thompson
Comment Utility
That would be awesome!  Thank you Perarduaadastra!
0
 
LVL 15

Assisted Solution

by:Perarduaadastra
Perarduaadastra earned 500 total points
Comment Utility
Well, it's all come flooding back...

Using PuTTY, connect to the unit's serial port with the following settings: Baud rate 9600, data bits 8, parity None, stop bit 1, and flow control None. You can configure these settings in PuTTY by clicking on Serial at the bottom of the left pane and editing the settings in the right pane as appropriate. Once you have settings that work, save them in PuTTY under a name that identifies the connection. A word of caution here - if you're using a USB-to-serial adapter it is likely to be assigned a different COM port on subsequent plug-ins, so always check what port it's been given and edit the port number accordingly in the connection window if necessary.
I found that the initial connection simply gives a green cursor; you have to hit Enter to get the prompt for a username. If the unit has been factory reset then there is no password - you set that as part of the initial configuration.

If for some reason you can't get the serial connection to work, the switch will default to the IP address 169.254.100.100. Shrewd fellow that you are, you will notice at once that this is in the very same subnet that a Windows PC will be assigned in the absence of a DHCP server, so you can just connect a laptop that expects an IP address to be forthcoming from a DHCP server to the switch with an Ethernet cable, wait a minute or two for the excitement to die down, and connect by typing http://169.254.100.100 in your browser address bar and hitting Enter. Then follow the instructions in the PDF I gave you the link for earlier.

If the firmware is really old then you may have to try different browsers to get one that works a) as expected, and b) at all...

You can find the firmware version by opening the CLI and typing:   show running-config   and hitting Enter.

Hope this helps.
0
 
LVL 8

Author Comment

by:Scott Thompson
Comment Utility
Oh my gosh!  You won't believe this!

I set the baud rate to 9600 as suggested by Perarduaadastra and it finally came up with asking for user!

However, now I have a secondary problem.  According to the manual I downloaded (BTW, if I didn't answer this before, it is a V1), the default User is admin and default password is none.  But, I can't seem to log in.  I have pressed the reset in the front multiple times, holding it down for 10 seconds, letting go, then having it blink showing it's resetting.

Any suggestions?
0
 
LVL 15

Expert Comment

by:Perarduaadastra
Comment Utility
That's odd... A blank password is difficult to enter wrongly!

Have you tried the other usual password suspects? admin, password, 1234, netgear etc... Have you tried upper and lower case for admin?

Are you sure that all the other settings for the serial connection are correct? Serial links are quite fussy about their parameters and tend not to work well or indeed at all unless everything is spot on.

When you are able to log in and are invited to set the password, its maximum length is eight characters; the unit will appear to accept a longer password, but silently truncates anything over that length. I came across this nugget recently when I was looking for something else.
0
 
LVL 8

Accepted Solution

by:
Scott Thompson earned 0 total points
Comment Utility
You guys have been a great help!  I FINALLY got in!

Here's how it had to be done.

We got HyperTerminal running on a Windows XP machine.

Setup the connection to Baud 9600, Data Bits 8, Parity None, Stop Bit 1, Flow Control None.

Here's the part I didn't know.

When it asks you to log in, you've already gone too far!

Hit the reset button on the switch while it's hooked up for at least 3 seconds, then let go.

On HyperTerminal you will see the machine going through a boot sequence.  In here, you can interrupt the boot and reset the unit.  That cleared out the password and made it so I can get in with just Admin and blank!
0
 
LVL 15

Expert Comment

by:Perarduaadastra
Comment Utility
Well, I have to say that I didn't know that either! I'd be inclined to say that I merit only half the points as I provided only half the answer, but I'm not sure if the points award system is that flexible.

That piece of information seems to me to be a worthy addition to the EE database, as it's a technique that might apply to other hardware too.
0
 
LVL 8

Author Closing Comment

by:Scott Thompson
Comment Utility
The complete answer is in the solution I provided, but I came to this conclusion due to the comments marked.
0

Featured Post

Scale it in WD Gold

With up to ten times the workload capacity of desktop drives, WD Gold hard drives employ advanced technology to deliver among the best in reliability, capacity, power efficiency and performance.

Join & Write a Comment

Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now