Extended C: drive in ESXi not extending

I just extended a C: drive from 40GB to 160GB with the VMware vCenter Converter Standalone and the disk keeps showing as 40GB.  However, in Windows Disk Management shows as 160GB (see pic). I already tried rescan, etc. Any ideas?
DiskExt.PNG
IDMAAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
In diskmanagement shring the disk by about 10MB. Windows usually wants a little free, unpartitioned space to properly reflect the partition's size.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
0
andyalderCommented:
Use the extend filesystem command in diskpart, instructions are in the "more information" section of http://support.microsoft.com/kb/832316
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

IDMAAuthor Commented:
rindi,
The shrink won't allow me to do it.  The Shrink button stays grayed out.

Andrew,
The virtual machine version I choose was 10.  Would that make a difference?
Shrink.PNG
0
rindiCommented:
Maybe run a defrag as the image you posted suggests you to do.
0
andyalderCommented:
You'd think MS would have built a re-check into the extend volume option of diskpart and the GUI so that if it failed like it has for you it would automatically re-do the extend filesystem for you. I wouldn't run a defrag until you extend the filesystem with diskpart.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Virtual Machine selection should not cause this issue, but I would recommend version 8.0, unless you need the features of v10.

To be honest, I would try again...
0
IDMAAuthor Commented:
Andrew,

This is my third try....

I did one a couple of months ago and it worked just fine. Hmmmm
0
andyalderCommented:
You can always try allocating a bit more space with VMware then extending the partition again but the extend filesystem option normally fixes this problem. (you don't mention if you have tried it or not even though I have mentioned it twice).
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You've done this three times, this conversion ?

and three times it's failed ?
0
IDMAAuthor Commented:
andyalder,

Third time's a charm, sir.
I followed the steps on the More Information section and now I have the extra space.

I must admit, I'm a bit disappointed on the Converter.
0
andyalderCommented:
It's not a VMware problem, NTFS.SYS is to blame. It happens on physical Windows servers as well.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.