Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Windows 7 Automatic Updates Disabled by Administrator

Posted on 2014-11-23
9
Medium Priority
?
2,988 Views
Last Modified: 2014-11-23
Unable to configure automatic updates on this Windows 7 Pro 64bit - workgroup (read: non-domain) machine:
Control Panel > Windows Update > Change Settings
Under "Important Updates", the drop-down menu for automatic updates is set to: "Never Check for Updates (Not Recommended)" and is grayed out, cannot be changed. Top of window reads "Some settings are managed by your system administrator." Windows Updates works properly when initiated manually, so the system is up to date.

I am attempting to change these settings from an administrator account. I've attempted to create a new local administrator account and found the same results.

Local group policy setting for "Remove access to use all Windows Update Features" is set to "disabled".
BITS, Cryptographic services, and Windows Update services are all set to "Automatic".

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate permissions AND
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
set to "Full Control" and "Read" for Administrators group.

Malware scans unremarkable, running Microsoft Security Essentials on this machine.

Any advice to get this setting changed would be greatly appreciated and welcomed. Thanks!
0
Comment
Question by:Chris Nalberczinski
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +2
9 Comments
 
LVL 37

Expert Comment

by:Neil Russell
ID: 40460606
Has it ever been on a domain and removed?
0
 
LVL 97

Expert Comment

by:John Hurst
ID: 40460609
Did you set some local policies on this computer to stop updates?  That is the only way I know to grey out Updates.

Try running System File Checker to see if it can correct the problem. Open an admin command prompt and run SFC /SCANNOW twice. Allow to complete, restart and test.
0
 
LVL 34

Expert Comment

by:Michael-Best
ID: 40460616
See this guide titled: Windows 7: Windows Update - Enable or Disable "Who can install updates" Setting by: sevenforums.com

Link:
http://www.sevenforums.com/tutorials/112765-windows-update-enable-disable-who-can-install-updates-setting.html
0
The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

 

Author Comment

by:Chris Nalberczinski
ID: 40460638
System may have been on a domain at one point, but I'm not sure... any way to verify?

sfc /scannow got to 36% and failed "Windows Resource Protection could not perform the requested operation."
0
 
LVL 97

Expert Comment

by:John Hurst
ID: 40460639
You may need to try a Windows 7 Repair Install. You need the Windows 7 DVD to do this. There is a Seven Forums Tutorial you may be able to find. I will post a link when I get  back my computer.
0
 

Author Comment

by:Chris Nalberczinski
ID: 40460643
I'm familiar with the process - I'll give it a shot.
0
 
LVL 34

Expert Comment

by:Michael-Best
ID: 40460656
If you need to repair or re-install  win. 7 , then see this guide by: wikihow.com/Reinstall-Windows-7

Link:
http://www.wikihow.com/Reinstall-Windows-7
0
 
LVL 71

Accepted Solution

by:
Qlemo earned 2000 total points
ID: 40460691
I would try to rename the HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate regkey (I usually prefix a minus, to make it obvious and reversible). That should disable all policies, and only make the current AU settings in HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate active.
0
 

Author Comment

by:Chris Nalberczinski
ID: 40460695
Thanks Olemo for pointing me to the answer - appears that someone added a NoAutoUpdate=1 value to HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate. Once I deleted it, all was well with the world.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Configuring Remote Assistance for use with SCCM
An introduction to the wonderful sport of Scam Baiting.  Learn how to help fight scammers by beating them at their own game. This great pass time helps the world, while providing an endless source of entertainment. Enjoy!
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question