Link to home
Start Free TrialLog in
Avatar of Castlewood

asked on

Why only my Mac Air cannot access my externall hard drive?

I am unable to see or access my passport external hard drive….. On my Mac air-book. I was able to access last week.   When plugged in to a port (and I’ve tried both sides) it is running…the light on the drive is on and it’s running, but I can’t see it and it will not load any “previous” files.    I’ve opened and looked for it on disc utility as well… it’s not there.    I’ve rebooted…. I’ve unplugged, replugged….   I’ve tried with and without power attached.   I’ve tried with and without wifi.     I’ve completed an SMC reset….    No luck.    It does not show up.

Now the odd part -   If I plug it into my wife’s macbook air – it’s fine.   I can see it, access files, etc. etc.    So the issue is only on my computer? What could be wrong?
Avatar of Aaron
Flag of United States of America image

It sounds like it isn't recognizing the device. I would uninstall the drivers or roll them back. If you go the route of uninstalling the drivers just install the ones that came with the disk. Generally if you plug into a different port it will try to reinstall the drivers on plug and play devices so you can try that if you haven't yet.

Another thing you can try is turn off the Mac Book and then plug everything in and then boot up the computer.
Avatar of Castlewood


Thank you for the reply.
Can you elaborate more about how to uninstall the drivers or roll them back please?
Have you by any chance just updated your operating system to Yosemite?

There is a very long thread here about problems with Yosemite not mounting external USB drives and a variety of suggested fixes, some of which work for some people.
Sorry, left out the link in my previous post but one:
Well with mac I believe you call it the "Time Machine" to do a full restore to when the drivers were working. My understanding is that without additional configuration it is hard to just roll back a driver like you would on windows. If you are having the issue Strung suggested then it should take care of that as well so that is why I would suggest this as it tackles it in a way that would solve the problem no matter what the issue is (at least in most cases).

This should help:
This thread:

suggests a third party utility "Kext Utility 2.6.1" could fix your problem:

Also, make sure that in your Finder Prefs you have the boxes checked to show external disks on your desktop and in your sidebar.
Creating a new test user, logging in as that user and testing can help diagnose the problem as
User or System related.
Starting in Safe Mode (SHIFT key down at startup) can sometimes narrow the focus.

A client had USB port problems, Safe Mode, Reset PRAM and reset SMC were done and the problem was gone. I suspect the SMC reset was the cure.
If you recently upgraded or installed something that may be the source of the problem.
This thread on Apple Discussions about MacBook Pro USB problems
For some, Reset PRAM worked, others the SMC Reset worked.
Sometimes downloading the latest COMBO update for your OSX version can solve it.
Avatar of strung
Flag of Canada image

Link to home
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Sorry for the delay.
You wouldn't believe that it is the usb3 cable. I changed to use another different usb3 cable and it works like a champ.