Solved

Issue with Mikrotik Bridging between ethernet interface and Vlan Interface

Posted on 2014-11-24
4
1,568 Views
Last Modified: 2014-11-30
I am using a Mikrotik Power router 732. I have a need to have interface 3 be an access port (no tagging). Then that be a L2 bridge to port 5 Vlan 97. Also want the Router to have L3 access to this bridge.

SO I created the Vlan interface, with the proper VLAN tag.
Created a bridge
Added both ether3 and Vlan interface to the bridge
Set an IP address (in proper subnet) and assigned to the bridge interface.

I can connect between the machine on the Vlan and the 732.
Neither can connect to the server that is behind ether3 (untagged)

If I turn off the bridge and assign the IP to ether3, then I can connect 732 to the other server.

I have looked at a number of online docs and all would lead me to believe that I am doing this correctly. Any idea what is wrong?
0
Comment
Question by:jrdolan1054
  • 3
4 Comments
 
LVL 14

Accepted Solution

by:
Otto_N earned 400 total points
ID: 40464674
I know nothing about configuring Mikrotik devices, but based on an article on their wiki site, I would suggest the following set-up:
/interface vlan add name=vlan-97 vlan-id=97 interface=ether5 disabled=no
/ip address add address=<IP>/<Mask> interface=vlan-97
/interface bridge add name=br-vlan97 disabled=no
/interface bridge port add interface="vlan-97" bridge="br-vlan97" disabled=no
/interface bridge port add interface="ether3" bridge="br-vlan97" disabled=no

Open in new window

The examples I found all assigned the IP address to the VLAN interface, not the Bridge.
0
 

Author Comment

by:jrdolan1054
ID: 40464736
that is what I based my solution on. It is still not functioning properly.
0
 

Assisted Solution

by:jrdolan1054
jrdolan1054 earned 0 total points
ID: 40464892
After much more testing I think I found the issue is not that it is not working, but that the device on the other end was broken (having issues with BPDU packets).
0
 

Author Closing Comment

by:jrdolan1054
ID: 40472325
that is in fact the correct config.
0

Featured Post

Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Clarification about access via WAN 6 30
Changing password for HP switch 5 36
Vyos VLANs 14 33
EIGRP Bandwidth 9 18
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question