Problem with Subreport displaying in Main report on some programs

I have a CR that has 2 subreports.  When I run the CR in my Crystal report application, everything runs fine.

However, this report is copied to a stand alone program called uniPoint that is a Quality Management Software System.  When I run the report in here, 1 subreport displays as it should and the other one does not.

Any idea of what I should be looking for?
LVL 4
ITworksAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mlmccCommented:
Are you using the same printer?

mlmcc
0
James0628Commented:
What do you mean by "does not"?  Does not display at all?  Does not display in the desired location (eg. it's on a different page)?  Is not "formatted" properly (In what way?)?

 James
0
ITworksAuthor Commented:
does not display at all    I'm not printing it   just using preview within the application
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

mlmccCommented:
Crystal uses the printer driver to display the report.  But the printer driver shouldn't have that much of an effect to make one not display at all.

I assume you have checked page 2 of the report just incase the printer changed the pagination.

Are you using the same database?  Same parameters?

Any row level security on the database?
Is it the same user?

If it is different users have a user who sees the second subreport try logging into a machine that normally doesn't show it.  Also have the user who doesn't see the second subreport log in to a machine that sees the subreport.

mlmcc
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
James0628Commented:
Since you're using something else (uniPoint) to run the report, and I'm not familiar with it, there's no telling how that might be affecting things.  You could try something basic like removing the subreport that works, in case having 2 subreports is somehow causing a problem.  And if the subreports are in different sections, you could try moving the non-working subreport to where the working subreport is located.

 James
0
ITworksAuthor Commented:
I have no idea what happened....but after my mini vacation I came back today thinking I needed to work on this some more and the report is running fine and displaying everything like it should.  I swear it wasn't working last Tuesday.  In fact, I had someone else run it from her pc and she got the same results....so I know I'm not losing my mind.   :-)
0
James0628Commented:
I hate it when problems just go away like that, because you can't be sure that they won't just come back one day.  Hopefully it was just some temporary problem.

 James
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.