Link to home
Start Free TrialLog in
Avatar of RadhaKrishnaKiJaya
RadhaKrishnaKiJaya

asked on

Server Error in '/' Application

Hello Experts,
I converted a dot.net web project from vs 2003 to vs 2010.  It is running fine in my local machine.  But when I deployed it in our web server with Windows 2008 OS, I am getting the below error.  Please see the attachment.  I am using the right Framework 4.0 in web.config file.  Also, in IIS, I did the necessary changes.  Do you have any idea?  Thank you in advance.
RuntimeError.png
Avatar of Dave Baldwin
Dave Baldwin
Flag of United States of America image

That message is telling you what to do to be able to view the error.
Avatar of Mike
Mike

Try accessing the site from the server itself, you should get a more descriptive error.
Avatar of RadhaKrishnaKiJaya

ASKER

Mike,
Thank you!  I did try from the server and getting exact same error message.

Thank you!
Can you upload a screenshot of the one ran from the server not a client.
It is exact same Runtime Error.
That's odd, it should be different as the one above suggests that remote errors are disabled. Are all the required application pools started and set to use the new version? It's kind of hard to diagnose without an actual error though.
ASKER CERTIFIED SOLUTION
Avatar of Dave Baldwin
Dave Baldwin
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I think the default 'mode' does not display any errors.  This is what I had to put in my 'web.config' to show errors in the browser.  I would imagine that a .NET application will have more in that file.
<?xml version="1.0"?>
<configuration>
    <system.webServer>
        <httpErrors errorMode="Detailed" />
        <asp scriptErrorSentToBrowser="true"/>
        <urlCompression doDynamicCompression="true" doStaticCompression="true"/> 
    </system.webServer>
    <system.web>
        <customErrors mode="Off"/>
        <compilation debug="true"/>
    </system.web>
</configuration>

Open in new window

SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Dave/Mike,
I changed a new application pool with Integrated mode and applied that to the Basic Settings.  It is working now.  Thank you guys for your quick response.   I have no words.
Already mentioned the reasons.