Solved

can't RDP into server 2012 server in a workgroup (not on domain)

Posted on 2014-11-26
7
587 Views
1 Endorsement
Last Modified: 2015-01-18
I have a 2012 Server that is not on a domain, it is in a workgroup. I have a computer on the same LAN/SUBNET and I cannot log into it remotely. I get the following error:

To sign in remotely, you need the right to sign in through Remote Desktop Services. By default, members of the Remote Desktop Users group have this right. If the group you're in doesn't have this right, or if the right has been removed from the Remote Desktop Users group, you need to be granted this right manually.

Remote Services is enabled on this server.
1
Comment
Question by:Gelly77
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 88

Expert Comment

by:rindi
ID: 40466907
Have you added the user to the remote desktop user's group, as suggested in the message you got?
0
 
LVL 3

Assisted Solution

by:TropicalBound
TropicalBound earned 166 total points
ID: 40466912
To grant this access, open the Local Security Policy

Expand Local Policies and select User Rights Assignment.  Right click on the policy named “Allow log on through Remote Desktop Services” and select Properties.

Add the user(s) to the policy.

TB
0
 
LVL 95

Assisted Solution

by:Lee W, MVP
Lee W, MVP earned 334 total points
ID: 40466985
While TropicalBound's suggestion may work, the proper way to do this is as rindi said.

Open computer management from the administrative tools or run compmgmt.msc from an administrative command prompt and expand Local Users and Groups under System Tools.  Click on Groups and then in the middle pane with the list of groups, open Remote Desktop Users and add the account you want to log in with to that group.  It SHOULD allow you to connect without a log off / on or reboot.

See graphic below.RD Users in Computer Management
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 

Author Comment

by:Gelly77
ID: 40470329
I have tested a few different solutions:
1. Added username to Remote Desktop Group - did not work
2. Added username to Allow log on through Remote Desktop Services in local security policy - did not work
3. Remove Everyone group from Deny log on through Remote Desktop Services in local security polity- worked but this cannot be used as it leaves RDP open to everyone.

Any Suggestions?
0
 
LVL 95

Assisted Solution

by:Lee W, MVP
Lee W, MVP earned 334 total points
ID: 40470738
The DEFAULT setting lists NO ONE / NO GROUP in Deny log on through Remote Desktop Services
Why did you change this?

Windows permissions are MOST RESTRICTIVE.  And they do NOT permit something if not EXPLICITLY granted.  It sounds like you broke this yourself when you (or someone) added the everyone group to the Deny log on through Remote Desktop Services.

Fix that.  Then grant only those you want to have access.  Post SCREEN SHOTS of errors before you make additional changes (once this has been done).
0
 

Accepted Solution

by:
Gelly77 earned 0 total points
ID: 40546492
I had to remove the everyone and the administrators group from the deny logon through remote desktop services. All is working now!!!!
0
 

Author Closing Comment

by:Gelly77
ID: 40556015
My solution resolved the issue. The comments from the other submitters assisted me in getting to the solution.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question