• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 385
  • Last Modified:

The workflow could not update the item in the external data source. Make sure the user has permissions to access the external data source and update items.

We have SharePoint 2013 On-Premise. I am setup External Content Type which connects to a table in SQL database. An External List has been setup correctly in SharePoint 2013 designer which displays data from this SQL Table. The connectivity to SQL table from this external list is working correctly. I have another list which needs to update this external list via a simple workflow action. This is where I receive this "The workflow could not update the item in the external data source. Make sure the user has permissions to access the external data source and update items." error. Now all the permissions are setup correctly on the SQL table, SQL database, Set Object permissions (in BCS) and Set Metadata Store permissions. Secure Store services is also working correctly. Still no luck updating the External list from workflow.

Any hint, suggestion or has anyone resolved this
0
Snehal Rana
Asked:
Snehal Rana
  • 4
  • 2
1 Solution
 
colly92002Commented:
Can the user edit the BCS data in a datasheet view?

Are you using kerberos?  If not, have you configured BCS to use SQL accounts or NT impersonation?  NT will potentially be problematic because of double hop.  

Check ULS logs for more detailed error.  If it complains about anonymous user its probably a kerberos/double hop issue.
0
 
Snehal RanaSenior SharePoint ConsultantAuthor Commented:
>Are you using kerberos?
We are using NTLM. There is Kerberos authentication present but not for the main Web Application.

> If not, have you configured BCS to use SQL accounts or NT impersonation?
No I have not tried using SQL Accounts nor NT impersonation

>Check ULS logs for more detailed error.  If it complains about anonymous user its probably a kerberos/double hop issue.
I did check ULS logs for this but will check for anonymous user

Appreciate your response
0
 
colly92002Commented:
If using NTLM you must also configure Secure Store Service, which is very poorly documented and a pain to get working in my experience.

Here is a good walkthrough:
http://www.fabiangwilliams.com/2010/04/16/how-to-create-configure-consume-sharepoint-2010-secure-store-in-business-connectivity-services/

If no kerberos then I strongly recommend setting up a test connection using SQL accounts and getting that working first.  I have never got impersonation to work in a farm environment without kerberos support (beucase of the aforementioned "double hop" problem).  SQL experts may be able to suggest best practice.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Snehal RanaSenior SharePoint ConsultantAuthor Commented:
I was able to configure this using the latest Service Pack update from Microsoft which fixes this issue.
0
 
Snehal RanaSenior SharePoint ConsultantAuthor Commented:
I have to close this question because the resolution of the issue was provided by Microsoft Support as I have mentioned above.
0
 
Snehal RanaSenior SharePoint ConsultantAuthor Commented:
We had to involve Microsoft Support in resolving this issue. There is a Service Pack update out there which resolves the exact same issue. Below are the patches that will resolve this issue successfully:

[1] https://support.microsoft.com/kb/2767999  (this update needs to be applied first before the second one)

[2] http://support.microsoft.com/kb/2882987/en-us 

[3] https://www.microsoft.com/en-us/download/details.aspx?id=42898
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now