Exchange 2010 Room Mailbox Auto-Decline with Delegate

Hi,

We are using Exchange 2010 SP3 with Rollup 7 on Windows Server 2008R2 SP1, and have set up resource mailboxes.

We have found that we can have the system automatically process the calendar requests, or we can use a delegate.

Is it possible to have both? Ideally, we would like "In Policy" requests to be directed to the delegate for approval, and "Out of Policy" requests to be automatically declined.

If so, we have been unable to get it to work.

This is the current output of Get-CalendarProcessing "Meeting Room" |fl : (some items blanked for privacy)

RunspaceId                                      : 502a67f1-293d-41c2-bafa-aacf957e8046
AutomateProcessing                      : AutoAccept
AllowConflicts                                  : False
BookingWindowInDays                  : 180
MaximumDurationInMinutes        : 1440
AllowRecurringMeetings                : True
EnforceSchedulingHorizon            : True
ScheduleOnlyDuringWorkHours  : False
ConflictPercentageAllowed            : 0
MaximumConflictInstances            : 0
ForwardRequestsToDelegates      : True
DeleteAttachments                         : True
DeleteComments                             : True
RemovePrivateProperty                  : True
DeleteSubject                                    : True
AddOrganizerToSubject                   : True
DeleteNonCalendarItems               : True
TentativePendingApproval             : True
EnableResponseDetails                   : True
OrganizerInfo                                    : True
ResourceDelegates                          : {domain.local/users/xxxxxxxxxxxxx}
RequestOutOfPolicy                         : {}
AllRequestOutOfPolicy                    : False
BookInPolicy                                      : {}
AllBookInPolicy                                 : False
RequestInPolicy                                : {}
AllRequestInPolicy                            : True
AddAdditionalResponse                  : False
AdditionalResponse                         :
RemoveOldMeetingMessages        : True
AddNewRequestsTentatively          : True
ProcessExternalMeetingMessages : False
RemoveForwardedMeetingNotifications : False
MailboxOwnerId                                : domain.local/Users/Meeting Room
Identity                                                : domain.loca/Users/Meeting Room
IsValid                                                  : True
NanosphereAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

imkotteesSenior Messaging EngineerCommented:
Hi,

I don't think automatic processing and delegate work together, it will forward the request to delegate mean while it would accept it.

For achieving your goal you may try this.

AutomateProcessing                      : AutoUpdate
AllRequestInPolicy                          : false
RequestInPolicy                               : {user1, user2, user3 & etc.,)
ResourceDelegates                         : {domain.local/users/xxxxxxxxxxxxx}
0
NanosphereAuthor Commented:
Hi,

Thank you for the response.

I was afraid that may be the case. I tried those settings anyway, but it didn't seem to help.

Is there usually any delay when changing these settings?

In case I accidentally stumbled upon the answer and didn't give it time to take effect.
0
NanosphereAuthor Commented:
Hi again,

I seem to have located the problem. It was in the target calendar delegate settings. Apparently, It doesn't like 'My Delegate Only' as per below. Once I changed it to the recommended setting, conflicting events were automatically declined.

Capture.PNG
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
NanosphereAuthor Commented:
Figured out solution myself. Seems an unusual setting to throw off the auto-decline, but there you go.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.