virtual memory low

Hi Experts,
I got a message today when logged in remotely to my pc, virtual memory low, windows increasing... (see attached), what do I have to do to fix this problem?
untitled.bmp
LVL 5
bfuchsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
First of all you should start thinking of replacing XP with an OS that is still supported and not obsolete.

Your pagefile is either too small, or you have too much software running on your PC. Close what isn't necessary. You can also increase the the size of the pagefile, or set it to system managed.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bfuchsAuthor Commented:
@Rindi,
Thanks for replying,
Where do I change the settings of pagefile and to what value should this be set?
Thanks,
Ben
0
dbruntonCommented:
To adjust read here https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/sysdm_advancd_perform_change_vmpagefile.mspx

Note Microsoft's recommendation and Click on System managed size.

That will automatically adjust the size upwards if your Paging File gets too small.

--------------------------------------------------

However from your graphic it seems that your Paging File is already System managed and Windows is just giving you an information message.

Note Rindi's comment on too many applications open.  You may also have a memory shortage in your computer.  Consider adding more memory.  If you board supports it you might consider going up to 4 Gb of memory.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

rindiCommented:
Right click "Computer", select "Properties", then "Advanced", and under Performance "Settings". Now again "Advanced", and in Virtual Memory "Change". Now you can select how the pagefile(s) should be.

How it/they should be set depends on your system and disk partitions, and free space.

Normally the pagefile should be 1.5x the size of your RAM.

Normally I have a relatively small partition for C which is for the OS and nothing else. Another partition (D) is for the data and software I install. As C isn't very large I only have a very small pagefile (256MB so that minidumps can be created), and on drive D I use a system managed pagefile. System managed pagefiles will automatically increase their size if needed, but they should also be on contiguous space on the disk, so the disk should be defragged and there should be enough free space on it.
0
bfuchsAuthor Commented:
Hi Experts,

FYI, this is relatively not that old pc at all, the reason I have this OS is simply because we have some programs that are currently not compatible with new windows versions.
I am attaching some screenshots from the computer's specs, so you can see if there is something wrong with the setup.
additionally I am also attaching a screenshot of the task manager while all those programs are running, from where you can see that its not even using a quarter of the full qty.
According to these, let me know how to proceed

Thanks,
Ben
untitled.bmp
untitled2.bmp
untitled3.bmp
0
dbruntonCommented:
In your third picture click on System Managed Size.

For best performance do NOT set your Page File to Custom size as you have done.  Leave it at System Managed Size.
0
rindiCommented:
Either set the minimal pagefile size to be equal the maximum size, In your case, you seem to have about 3.2GB RAM, so 1.5 times that would make the optimal size to be about 4.8GB. So either set it to be min=4800MB and max=4800MB, or just set it to "System Managed size", that usually is fine. But never set a minimum and maximum size that is different, that causes the message you get, and it isn't efficient.

Most software that runs under Windows XP can also be made to run under Windows 7, and if not you could still use Windows XP mode for that particular software. You should really upgrade the OS to Windows 7 and then try getting your software to run under it
0
bfuchsAuthor Commented:
OK, I see you both agree that System Managed size would work for me, so I am following that path.
Thank you!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.