Resource interpreted as Script but transferred with MIME type text/plain:

Hi.
I have an asp.net angular application using visual studio 2013.
ok. if I run this application with IISExpress, it works fine. but, if I change to IIS, I got the title message above.

the source code of the page looks good, but the angular view is not loaded, so the display is totally empty.

thx in advance
Deraldo SilvaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RobOwner (Aidellio)Commented:
This is a message from the browser because the MIME type is serving your script file (javascript?) as text.  They should be served as text/javascript (assuming javascript).

When including javascript in your site you should use the type

<script src="..." type="text/javascript"></script>
0
Deraldo SilvaAuthor Commented:
thx Rob for your attention.
I put type=text/javascript and text/css in all scripts and css and I still got the problem.

but why this would be a problem in IIS and not in IISexpress?
0
RobOwner (Aidellio)Commented:
Because you can control how certain extensions can be served with what mime types. Maybe it's a default in the express version but is more flexible in iis?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

RobOwner (Aidellio)Commented:
I'll check my setup and get back to you
0
Deraldo SilvaAuthor Commented:
ok. thx.
0
RobOwner (Aidellio)Commented:
yes, it looks like IIS you can specify the MIME type based on any extension.  Please confirm what you have for your .js and .css extensions as indicated by this screenshot of mine:

Capture.JPG
0
Deraldo SilvaAuthor Commented:
Hi Rob,  I think that you find the problem. But, I am using windows 8.1 pro. I could not find the Mime types in IIS to change. Could you help?

thx in advance.
0
RobOwner (Aidellio)Commented:
i'm also using windows 8.1 pro! :)

Capture.JPG
0
RobOwner (Aidellio)Commented:
Just check that you've got the same options installed:

Clipboard01.jpg
0
Deraldo SilvaAuthor Commented:
Ok. I got the Mime Types. Thx for your help.
Checked. all types are set correctly.

Meanwhile, I created another angular project, from scratch and it works ok. So I think the problem is the solution.

I will recreate my solution.

thx for your help and attention.
0
RobOwner (Aidellio)Commented:
That's good to hear. At least you knew by ruling things out that it was your solution causing the issue.

Glad to have helped.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
JavaScript

From novice to tech pro — start learning today.