Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1835
  • Last Modified:

Light blue screen after F12 on PXE - WDS Server 2012 R2

Hi Experts,

We set WDS on a 2012 R2 server.
Do not listen on port 67 is activated.

DHCP is on another server which is set like this :

43 : 010400000000FF
60 : "PXE Client"
66 : IP of the WDS Server
67 : "boot\x64\pxeboot.com" (Like in the wdsutil /get-server /show:config result for x64)

We tried on a VM, the Hyper-V server is the same than WDS by the way, all is working fine until we choose the boot image (We tried with many boot images (boot.wim from Win7x64 disk, creating  different images with WAIK and so on), the result is always the same...
stuck on a black screen. When we choose safe mode we can see that the disk.sys or ahci.sys driver (depending of the boot image) is not loading.

We tried also on physical computers, the behavior is different, whatever we choose to force F12 or to boot automatically, we need to press F12.
There is no choice of the boot image, a light blue screen appears for a while, then the computer boots from his usual boot order.
 We tried to force approbation by administrator, the F12 key is asked to be pressed and the light blue screen appears...
Nothing in the Waiting for approve tab, so it is not wirking...


Any idea ?

PS : I tried to chanbe the 67 DHCP option with always the same result :
On the the VM, HDD driver is not loading, black screen forever.
On the physical machines, always F12 asked with the light blue screen for a while the normal boot .


Thank you in advance for your help !
0
jet-info
Asked:
jet-info
  • 3
2 Solutions
 
A KarelinCommented:
What the error was on the blue screen? Are your servers and clients in the same subnet? If no Do you use iphelper in network devices for your dhcp server?
0
 
jet-infoAuthor Commented:
Hi,

This is not a BSOD, just a light blue screen with no text...

Servers and clients are on the same subnet.

PXE is working since the right boot server is found.
0
 
jet-infoAuthor Commented:
I finally fixed it, I removed the Remoteinstall folder (renamed in remoteinstall.old in fact) and laucheded the command  wdsutil /uninitialize-server. Then I reconfigured the the WDS server like it was. Finally I set the 67 DHCP option to boot\x86\wdsnbp.com

I hope that it can help someone...

PS : It was another error, the WDS service didn't start after a fresh install when it was linked to the AD. The problem was that the Winsdows Server OS was installed in French and a registry key was set with domainadmins in English by default... Thanks Microsoft... I loose hours with that problem because I looked only on English forums...

The Key to edit is

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WDSServer\Providers\WDSPXE\Providers\BINLSVC\AutoApprove\<arch>

Where <arch> is the architecture like x86, x64, ia64 and so on...

Set the "User" DWORD objet with "Administrateurs du domaine" for each <arch> Key.

Restart the WDS service and voilĂ ...


Thank you for your help.
0
 
vivigattCommented:
I know you solved your problem, but there is something wrong with your config.
Your DHCP options are not correctly set.
Check my article and its comments for more  details about when to set DHCP option 60 and why you should NEVER set DHCP option 67 and 66 when you have a real PXE server on your LAN.
http://www.experts-exchange.com/Networking/Misc/A_2978-PXEClient-what-is-it-for-Can-I-use-PXE-without-it.html
0
 
jet-infoAuthor Commented:
I hope that it could help someone...
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now