POP2Exchange wrong pickup loc

Hi, recently I noticed mails being pulled by GFI Pop2Exchange aren't delivered anymore in the user's mailbox.  Looking at the Pop2Exchange Logfile, log says that mails are being downloaded and put in Pickup Directory.  However, my Exchange2013 pickup directory is standard location "C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\Pickup".  Using the command in Exchange Management Shell confirms that Pickup directory is indeed set to location mentioned above.
For some strange reason however, GFI Pop2Exchange puts the downloaded mail in .eml format in C:\ and thus Exchange Server doesn't pick them up.  Does anyone knows how to configure the GFI POP2Exchange setting where to put downloaded mails ? I already struggled through GFI knowledge base but no solution was found yet.  Hoping some of you can help me out as I discovered some GFI posts on this website as well.
Many thanks,
Marc
mhellemansAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tshearonCommented:
I wonder if it is dropping it there because Exchange is telling it to? Have you checked the location of your pickup directory?

Get-TransportServer your_server |fl pickupdirectorypath

If it is C:\ then do:

Set-TransportServer your_server -PickupDirectoryPath "C:\Your-desired_directory"

Usually C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\PickUp.
0
mhellemansAuthor Commented:
Dear tshearon,

I ran the command in Exchange shell and got following path:

PickupDirectoryPath : C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\Pickup

This is correct but still Pop2Exchange puts mail in C:\

I've tried many things already but unfortunately nothing solved the issue yet.

Many thanks for your help.

Marc
0
tshearonCommented:
Unfortunately I do not know a thing about GFI Pop2Exchange. Very sorry. If it doesn't have an option on the GFI config side to change where it puts the email files then I'm lost.
0
mhellemansAuthor Commented:
Same here.  Unfortunately I just can't seem to find the option to change pickup in GFI :-(
0
mhellemansAuthor Commented:
After contacting GFI helpdesk, they provider me new config.mdb file and now all works finr
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.