Office Search

I have a user I migrated from on premise to Office 365. After the migration of a 19GB email box the user is experiencing issues when performing searches. The user can search for a specific name which should bring forth hundreds of emails from ten years past but the search only shows items within the last year. The migration was successful and the mailbox does show 19GB of email still exists. Need to understand why the account does not provide a full search.
TabDBAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
retention policies may play a part here. and it will take a while to index 19GB .. your .ost is 19GB?
0
Vasil Michev (MVP)Commented:
Judging from the other question you opened, the user is on Outlook 2013, right? By default, only a subset of the mail will be downloaded when using Outlook 2013 in cached mode. To check if this is the case, go to File -> Account settings -> Account Settings -> double click the account in question and check the value of the 'cached mode' slider.

In addition, Office 365 comes with default "2 years move to archive" policy, as David noted above. It will move all the older messages to the archive mailbox, so check there as well, or make sure the search scope in Outlook includes All mailboxes and not just the current one.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TabDBAuthor Commented:
Outlook 2013 is correct. I set the user to only cache 3 months due to this taking a large amount of time set to 12 months. Since the cache only goes back 12 months I did not think this would help in the cause since he is searching back 8-10 years. I did remove the policy from this particular user this morning so that he does not have any type of archive applied. I am a little confused about what you are referring to as an archive mailbox. I have checked many accounts and I do not see an archive mailbox option. Keep in mind we paid for the E3 licenses for each user but we did not pay for the archive option. Not sure if that makes a difference here.
0
TabDBAuthor Commented:
I was incorrect on my last comment. I can see now that I can move the slider back to the "ALL" position and cache all of the email if I choose. This might fix the issue but will take a long time since he has 19GB. Do you agree that moving the cache slider to "ALL" could solve the issue?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Office 365

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.