How to uninstall Exchange 2007 on a SBS 2008

Hi all,

I receive the error in de screenshot, but as you can also see in the screenshot: there is no public database. I need to remove Exchange 2007.

I don't understand why Microsoft needs to check certain things before removal. I am the administrator, so when I say: remove, then I want to remove everything, including public.

Anyone any ideas on how to fix this?
AgrippaSenior IT ConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
there is no screenshot
0
tshearonCommented:
Can you provide the error you are getting? There is not enough here to help you.
0
AgrippaSenior IT ConsultantAuthor Commented:
Sorry!

The screenshot is now available
ee.JPG
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Satyendra SharmaMicrosoft UC Technical ArchitectCommented:
First of all screenshot is missing.

And if you are 100% sure that public folder is no need or backed up or whatever may be the case you may follow below steps to delete the database instance thru Adsiedit (this is not recommended method, and there is no going back)

Steps:
1.Dismount the Public folder database.
2.Remove public folder database from Exchange Management Console. If it failed, go to step 3.

3.Delete public folder from ADSI Edit:
a. Run"adsiedit.msc".
b. Expand "CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Adminstrative Groups,CN=Exchange Adminstrative Group(FYDIBOHF23SPDLT),CN=Servers,CN=Servername,CN=Information Store" then delete the Public folder database from the ADSIEDIT directly.
0
AgrippaSenior IT ConsultantAuthor Commented:
Hi Satyendra,

proceed with your method now that you have seen the screenshot perhaps?
0
Satyendra SharmaMicrosoft UC Technical ArchitectCommented:
I see it, do you have other exchange server running with public folder database on it?
0
David AtkinTechnical DirectorCommented:
In most cases I wouldn't suggest removing Exchange from SBS as it is linked in with everything else, I would just disable it (Obviously too late for that).

Do you just have the one server?  Are you moving to another mail system?
0
AgrippaSenior IT ConsultantAuthor Commented:
Hi all,

things got a little to complicated, so I decided to reinstall the server, since I had a deadline and the server whas freshly installed anyway. Since I will not be using 2011 SBS and this 2011 version is the last SBS ever of MS, I will accept having Exchange in 2008, eventhough I don't use it, I will disable all services and in the future use the non SBS versions.

Thankx all
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AgrippaSenior IT ConsultantAuthor Commented:
No really a solution, more a workaround
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.