Solved

Altaro reporting "Crash-consistent backup"

Posted on 2014-12-02
13
412 Views
Last Modified: 2014-12-13
I've been backing up my 2 Hyper-V guest machines using Altaro for a while now.  Everything was working fine.  But now Altaro is reporting "Crash-consistent backup".  I've run a "vssadmin list writers" and none of the writers have any errors.

There is nothing odd in the Event log for the VM guest that is failing on backup.  However, in the Event logs for the VM host I found this:
"VssAdmin: Unable to create a shadow copy: Either the specified volume was not found or it is not a local volume. Command-line: 'C:\Windows\system32\vssadmin.exe Create Shadow /AutoRetry=15 /For=\\?\Volume{f369330f-be43-11e2-b81d-001b21a9389c}\'. "

Per the MS knowledgebase http://support.microsoft.com/kb/833779 I found & deleted the Scheduled task that snapshots to Volume{f369330f-be43-11e2-b81d-001b21a9389c}.


http://www.mcbsys.com/techblog/2012/02/delete-orphaned-vss-task/

https://social.technet.microsoft.com/Forums/windowsserver/en-US/64127ca1-06d5-4f6e-9f3d-98e629a038c7/vssadmin-unable-to-create-a-shadow-copy-failure-either-the-specified-volume-was-not-found-or-it-is?forum=winserverfiles


Help?
0
Comment
Question by:cef_soothsayer
  • 8
  • 5
13 Comments
 
LVL 28

Expert Comment

by:asavener
ID: 40476525
Well, unless the backup software can quiesce the disk, you're always going to get a crash-consistent backup.  Even if you remove the VSS job that's throwing the error, you're still not quiesceing the disk (or, at least, your backup software doesn't detect that the disk is quiesced.)

I suggest setting up the job again in Altaro, and see if you start getting an application-consistent backup.
0
 
LVL 1

Author Comment

by:cef_soothsayer
ID: 40476709
Ok, I don't see how that will allow the backup to access the VSS, but you might be right.  At this point, I'll try anything.  I detached the VM from the backup, removed the VM's old backups, reattached the VM, and rescheduled the backups.  Now waiting to see how the backup runs.  Stay tuned...
0
 
LVL 1

Author Comment

by:cef_soothsayer
ID: 40478386
Nope, unfortunately that did't work.  :(  Any other ideas?
0
 
LVL 28

Expert Comment

by:asavener
ID: 40478466
Is there anything new on the VM that would be preventing the disk from quiesceing?
0
 
LVL 1

Author Comment

by:cef_soothsayer
ID: 40479215
Not that I know of.  I mean, It typically has an active RDP session, and a few apps and sometimes files left open, but nothing that is "changing" at the time of night that this backup runs.  I don't think that would be the issue because:  1.) That's never stopped the backup before.  2.) I've rebooted the VM and the backups still don't work.  3.) The backup is running on the VM host, not the VM guest.  The VM guest is unaware.  And the VM host isn't really running anything else.  Plus, it's been rebooted too.

Thanks.
0
 
LVL 28

Expert Comment

by:asavener
ID: 40479249
Well, if you just take a snapshot of a running VM, and then back up that snapshot, it gives you a crash-consistent backup.

If you quiesce the applications in the VM prior to taking the snapshot, then you get an application-consistent backup.

So the hypervisor has to send a notice to the guest, and get it to (very briefly) stop disk access.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 1

Author Comment

by:cef_soothsayer
ID: 40480054
Let me try to shut down the guest VM before backing it up, and see if that gets me anywhere.
0
 
LVL 1

Author Comment

by:cef_soothsayer
ID: 40480528
Ok, that did the trick.  Did two backups while the VM was offline and they were both successful.  Now I need to try again when the VM is running - as that is the ultimate goal.
0
 
LVL 1

Author Comment

by:cef_soothsayer
ID: 40482745
Nope.  Crash consistent.  :(
0
 
LVL 1

Author Comment

by:cef_soothsayer
ID: 40488772
Any other ideas?  Why wont this VM backup in a successful non-crash-consistent state when it is running anymore?  This worked just fine for months and months, and nothing was installed on the VM.  No changes prior to the problem starting...
0
 
LVL 28

Accepted Solution

by:
asavener earned 500 total points
ID: 40488798
My next advice is to call the backup vendor.
0
 
LVL 1

Author Comment

by:cef_soothsayer
ID: 40497247
NAILED IT.  Ok, this is definitely a facepalm moment.  But here's what happened.

A little while ago (about the time the backups started failing, but I didn't realize it) I was working on a P2V project and having trouble. (There is another Experts Exchange Question still open on that).  As part of the troubleshooting, I connected the VHD to this VM as a secondary drive in order to review the file contents.  Well, that VHD was on a USB connected Zalman drive, and when I was done, I downed the VM and removed the drive.  But I forgot to unmount the VHD in the VM config.  So after I unplugged the Zalman, and booted the VM back up, the secondary volume to the VHD was still mounted, but the drive could not be found.  Hence the Altaro backup errors.  It wasn't complaining about the C; drive at all.  It was complaining about the E: drive which was missing.  DOH!

So, problem solved.  Lesson learned.  My Bad.

But those error messages SURE COULD USE SOME MORE DESCRIPTIVE INFORMATION.  Sheesh...

Thanks for your assistance.
0
 
LVL 28

Expert Comment

by:asavener
ID: 40498010
Glad you found the issue.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Xen 6.1, 6.2 Poor NIC performance in ShadowProtect/WinPE 9 80
Backing up a vmware workstation 3 55
Solaris SUN OS 4.1.3 machine clone 15 40
pros and cons of RDS vs VDI 12 155
Will try to explain how to use the VMware feature TAGs in the VMs and create Veeam Backup Jobs using TAGs. Since this article is too long, I will create second article for the Veeam tasks.
Last article we focus in how to VMware: How to create and use VMs TAGs – Part 1 so before follow this article and perform the next tasks, you should read the first article how to create the TAG before using them in Veeam Backup Jobs.
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

26 Experts available now in Live!

Get 1:1 Help Now