Avatar of Starr Duskk
Starr Duskk
Flag for United States of America asked on

Installing asp classic and 4.5 framework on IIS8 Windows Server 2012

I've setup a new windows server 2012 with IIS8 site at Rackspace. I want to install ASP Classic and the 4.5 framework.

I've read how-to articles and they say when selecting roles to select "ASP" and "ISAPI" but those are not options in the Server manager.

When I go to the control panel, Programs, it shows only that .NET Framework 4.0 multi-targeting pack is installed.

thanks!
Windows Server 2012Microsoft IIS Web ServerASP.NET

Avatar of undefined
Last Comment
Starr Duskk

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Dan McFadden

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Starr Duskk

ASKER
That second one is very interesting. Because it says:
http://technet.microsoft.com/en-us/library/hh831387.aspx
7.On the Select Features page, note the preselected features that are installed by default, and then select the following additional role services:
◦ ASP
◦ ISAPI Extensions

But at Rackspace when I was setting this up in 2012 R2, those two options were nowhere to be found in the Roles. Can they remove them themselves? Or is that something new with 2012R2?
Starr Duskk

ASKER
Rackspace showed me where to find them, hiding under another topic. thanks!
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck