VMs on the same host cannot communicate

I have 2 VMs on the same ESXi 5.0 host, on the same vmswitch; they are the only VMs on this host.  They can communicate with the rest of the network with no problem and they can also browse the Internet, but they cannot ping or browse each other. The Windows firewall is turned off on both machines.  I have eliminated any DNS issues (one of the machines is DC and DNS server, and there is another DC/DNS server on the network as well), TCP/IP configuration issues, etc.  File and Printer Sharing is turned on for both servers. One is running Windows 2008R2 Standard, and the other is Windows 2008 Standard. The only conclusion I can reach is that it's something in the ESXi configuration.  Any ideas would be appreciated.
LVL 39
Hypercat (Deb)Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ajeabCommented:
did you check gateway setting?
0
Hypercat (Deb)Author Commented:
Yes, as I said, both machines can browse the Internet, so their gateway settings are correct.
0
David Johnson, CD, MVPOwnerCommented:
are they in the same subnet and vlan?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Have you checked ALL the network settings are the same, Subnet Mask ?

Firewall Disabled on both Hosts?

VMXNET3 interface installed, and VMware Tools ?
0
Hypercat (Deb)Author Commented:
@david - There is only one vlan. All devices at this site are in the same subnet, so if one or both of these machines had the wrong subnet, they wouldn't be able to communicate with anything else on the network.  This is a very simple network, about 65-70 devices total, one network/subnet, one hardware firewall router at the edge.

@andrew - same answer on the network settings.  Windows firewall is disabled by group policy, but I double-checked and it is definitely disabled for all profiles. They are using an E1000 driver for the network interface. I've never had a problem with these, but I could change it if you think it might fix the problem.  VMWare Tools are installed and the service is running.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Never use the E1000 for production, only use E1000 for installation.

Replace with VMXNET3, many more benefits.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mark GalvinManaging Director / Principal ConsultantCommented:
Have you checked DNS is configured correctly?
0
Hypercat (Deb)Author Commented:
Changing to the VMXNET3 driver even on just one of the virtual machines fixed the problem. I'm amazed that this made such a difference, especially since when you create a new virtual machine, ESXi defaults to using the E1000 driver for the NIC card. IMO, they ought to change this default if using the older driver can cause this kind of problem on the newer versions of ESXi.  Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.