Printing over WiFi

A couple of days back I switched on my ols computer again and.... it died. Along with it a few other components in my network died: one swith completely broke down and another lost a few ports. Those parts have already been replaced.
The last issue that I am aware of at this point are repated to my printer, an Epson PW700X all in one. It has lost its capability to print over (wired) LAN at the same time, but its wifi is still operational. My wife still manages to get prints off the thing using her laptoip and my andoid phone does so too,
The problem is that both my laptop and my sons don't.

My sons lapton runs Win 8.1 x64. My wifes laptop and mine run Win 7 x64. All three run the same Panda Internet security software, incl. firewall.
There has been no issue at all while the printer was operating on wired LAN. It is set to manual IP configuration for WiFi, the same settings at it had in its wired days: 192.168.33.222 / 255.255.255.0, gateway 192.168.33.1 (=Fritz!box 7390).

I've done some experimenting on my laptop: removed all Epson software, downloaded the latest (for x64) and installed it. No firewall warnings/blocks, the test page printed perfectly and the inserted SD card could easily be read. A 1st printjob from MS Office caused no problem either.

The next day however, the printer "could no be reached" and the mapping to the SD card could not be reestablished. I have not been able to fix the issue.

Any thoughts?
LVL 13
CRAKAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hdhondtCommented:
Just setting the printer's IP address will not necessarily make it reachable by the PCs.

Can you ping the printer from a PC? What are the PCs' WiFi IP addresses? From a DOS prompt, type IPCONFIG /ALL to check. Then give the printer an IP address in the same range. Next, create a new TCP/IP port for the driver with that IP address.
0
nobusCommented:
check also that the power to the device has not been cut, to save power
you can verify this from control panel - power settings
0
CRAKAuthor Commented:
@hdhondt:
All PC's have IP adresses handed out by DHCP: 192.168.33.x (these appear quite static due to the modem/router).
Will try ping later on; not sure if it ever responded to that before though. Will use both my and my wifes PCs for that.

I find your remark regarding a new TCP/IP port for the driver very interesting. Could you please elaborate some?


@nobus:
The thought of power save had crossed my mind. I'm I right that if my wifes PC has no issue waking up the printer, that this should not be an issue after a fresh install of the laters driver?
0
ON-DEMAND: 10 Easy Ways to Lose a Password

Learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees in this on-demand webinar. We cover the importance of multi-factor authentication and how these solutions can better protect your business!

nobusCommented:
it has nothing to do with drivers normally; but it does not hurt to check
0
hdhondtCommented:
If the printer's IP address is on the same subnet as the PCs (192.168.33.x) then it should work fine.
0
CRAKAuthor Commented:
Sorry to keep you all waiting.... a lot has happened, but I'm still looking for a solution.

Yes, all devices (PC's and printers) share the 192.168.33.x IP range.
I have installed a brand new PC on Win 8.1 and Panda: ping to the printer appears ok there. Printing itself as well.

On my laptop I have removed Panda all together (virusscanner and firewall), rebooted, enabled Windows firewall and enabled (and allowed) all file- and printer sharing (echo) requests: both in- and outbound, both IPv4 and IPv6.
Ping still raises time-out errors! I guess hdhondt is on the right track. I can't figure out what would still block the requests though.
Any thoughts?
0
CRAKAuthor Commented:
More info:
My wife's laptop CAN print, but also raises a time-out on ping.
:-(
0
hdhondtCommented:
If ping times out on a local network, it sounds as if you are having network problems.

It could be that the WiFi signal is weak at the printer's location. And PCs are much more forgiving about WiFi signals strength than printers. It's the main reason why I recommend using wired network connections with printers. After all, they do not need to move around (usually).
0
hdhondtCommented:
If I'm right, moving the printer close to the router should resolve the problems. Then you can try to find some suitable location for permanent installation. Of course, as the wired connection is not working either, this could imply that the problem is in the printer's network card.
0
CRAKAuthor Commented:
It's the main reason why I recommend using wired network connections with printers.
I agree, but as I wrote before: something happened on the wired LAN which caused me to loose switches and the printer's LAN port.

So now now I have this single printer (same device, but wifi) and a couple of PC's, all in the same network, connected to the same wifi/router.
I have placed two laptops close by each other. Both have a good connection. The printer has a fixed position and good connection.
1st laptop (wife): time-out
2nd laptop (mine): time-out
1st laptop (wife): prints ok
2nd laptop (mine): does not print (printer should be awake and connected)
A fixed PC (wired) does ping ok and does print.

At this point, I don't trust my laptop. I have removed Panda, rebooted and activated Windows firewall (default settings) -> no success.
Enabled everything related to ping -> can't get ping to work (while the fixed PC does!)
Disabled Windows firewall -> still no ping.

Is there a way to tell (detect) wich application (if any) still acts as a firewall?
0
nobusCommented:
look in event viewer for warnings , or errors
0
CRAKAuthor Commented:
Seen some errors and warnings, but nothing that seemed vaguely related to this issue.

However, there seems to be some progress:
Under "Network" in explorer, my laptop somehow became aware or the presence of a multifunctional device (my printer name), a printer (dito) asnd a scanner (dito).
It wasn't there yet under Devices and printers, so I clicked "add new printer". The expected printer showed up, raised an error, but at a 2nd attempt it seemed to work. Driver was (of course) downloaded from Windows update.
I even managed to print something!

Will give it another night to see if it'll stick around this time.
0
CRAKAuthor Commented:
Once again: it doesn't print. Not visible under network either.
No problem on other devices.
0
nobusCommented:
it looks like the wifi has a problem
i would start by looking in device manager if it is installed without error
then update the driver
if still problems, replace the wi-fi card - it may have taken a hit by your previous problems
0
CRAKAuthor Commented:
Drivers were up-to-date and I.M.O. it makes no sense: if wifi has a problem, then why is there no problem connecting to internet or other PC's over the very same wifi?

I've chosen the more extreme way to solve my issue: a restore to factory settings.
The most important stuff is reinstalled now (incl. over 200 Windows updates, Panda internet Security and the Epson drivers) and things still look ok after 3 days.
0
nobusCommented:
glad to hear it's running again
as for your Q  "if wifi has a problem, then why is there no problem connecting to internet or other PC's over the very same wifi?"   that is only possible to answer after the problem has been found

don't forget to close this Q ! unless you need more help
0
CRAKAuthor Commented:
Ehhh... I hate to say: I think the problem is back.
I wish I hadn't rushed to reinstall everything. I'm still not sure what caused it.
And worse: there seems to be some kind of a lag that was there earlier as well: one day it's fine, the next day it fails to connect.
I'm not ready to close the question just yet! ;-)
0
nobusCommented:
let me recapitulate:
-you use the internet over wifi - right? and no problems here?
-and the printer works fine for others - over wifi ?
i would recheck e'vent viewer for errors - there should be some indication now as to what is happening
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CRAKAuthor Commented:
That's right!
There were (again) some errors, but they point in the direction of the VAIO Care (VCAgent.exe; uncaught exception)

I reverted back to factory settings once more, recording when parts are (un)installed or updated. All windows- and VAIO updates have been processed. No other changes (as Panda or Epson) were applied and still that error occurred.
The printer responds to http requests and ping.

Then I removed the McAfee Internet security software and Norton online backup. After reboot http and ping still ok.
Installed Panda IS and got it up-to-date. After reboot still ok.
Removed Adobe Photoshop Elements and Premiere Elements (trials). After reboot still ok.
Removed MS Office 10 (trial). After reboot http and ping still ok.

I will install the Epson printer software shortly and continue tomorrow.
At that point I may be interested in a good way to record all the processes running after rebooting as eventually I will be installing stuff like Flash player and IMGBurn, that will try to add all sorts of rubbish like Ask toolbar with (or without ?) asking for my permission.
Is there tool that you could recommend? Screendumping the taskmanager (processes) would be my best attempt.
0
nobusCommented:
0
CRAKAuthor Commented:
Thanks, sounds good! Will put it to use first thing tonight!
(you're in B? I'm in NL)
0
nobusCommented:
right - i'm from Brasschaat
0
CRAKAuthor Commented:
Brasschaat? I must have driven by dozens of times on my way to Antwerpen, Wilrijk, Herentals...
I'm from Den Haag.

The tools is impressive: way too much detail. Escpecially since it keeps logging. A great check on how active a virusscanner actuallycan be! But actually I was hoping to get some kind of a snapshot it time to see what's running now and what's running once things have gone bad again.

At this point I've got most up and running and things still appear ok. Just a couple more things for the next few days (I don't want to rush things this time, rebooting and waiting after virtually every change). Will report back tomorrow.
0
nobusCommented:
ok - take your time
0
CRAKAuthor Commented:
Nearly completed. Ping, web interface and connection to the printers cardreader still ok. Printing too of course.
0
nobusCommented:
let's hope it's solved, and stays so
0
nobusCommented:
thanks CRak , happy to help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.