Solved

Question about OSPF

Posted on 2014-12-03
17
155 Views
Last Modified: 2014-12-05
Recently upgraded the circuit between two sites and this was the config that I used to use:

Site 1 (10.3.110.x)

interface FastEthernet1/0/2
 no switchport
 ip address 10.3.111.2 255.255.255.0

router ospf 1
 log-adjacency-changes
 network 10.3.110.0 0.0.0.255 area 0.0.1.1
 network 10.3.111.0 0.0.0.255 area 0.0.1.1

Site 2 (10.3.101.x)
interface FastEthernet1/0/2
 no switchport
 ip address 10.3.111.1 255.255.255.0

router ospf 1
 log-adjacency-changes
 network 10.3.101.0 0.0.0.255 area 0.0.1.1
 network 10.3.111.0 0.0.0.255 area 0.0.1.1

But I can't get the connection to work.  It is a private P2P connection.  The config above is the two ports on the routing switch on either end of the connection.  Am I missing something?
0
Comment
Question by:vianceadmin
  • 9
  • 8
17 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40479446
Can the router at Site 1 ping 10.3.111.1?

What do see from a "show ip ospf neigh"?
0
 

Author Comment

by:vianceadmin
ID: 40479455
No, it can ping 10.3.111.2 but that would be expected since it is on that site 1 switch.  That's what I've been trying to do is just ping the other interface from the switch...

When I do the show ip ospf neighbor, it's empty...Doesn't show me anything...

When I do the sh ip protocols, I don't see a gateway:
CLTCISCO01#sh ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 10.3.111.2
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    10.3.110.0 0.0.0.255 area 0
    10.3.111.0 0.0.0.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40479466
According to your original post, site 1 has an IP address of 10.3.111.2.

Site 2 has an IP address of 10.3.111.1.

So the first question is are your posted configs correct?

Second question is can site 1 ping site 2?
0
 

Author Comment

by:vianceadmin
ID: 40479474
Correct.  Site 1 has an IP of 10.3.111.2 and site 2 has an IP of 10.3.111.1.

You asked if site 1 can ping 10.3.111.1 (ip of site 2).  It cannot...Site 1 cannot ping site 2 (thus OSPF not working).  Appreciate the help...It's been a while since I've done this.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40479489
Please look at your original post. Specifically the IP addresses assigned to the site 1 FastEthernet1/0/2 interface.

Then look at the IP address assigned to the site 2 FastEthernet1/0/2 interface.

Now once again, is the config you posted actually from the equipment? (as in copy/paste)  Or is it something that you just typed in here?

If the neighbors can not ping each other (other their directly connected interfaces), no routing protocol will work.

It appears that there is a problem with your IP addressing.
0
 

Author Comment

by:vianceadmin
ID: 40479502
I copied it from my switches...This is how Cisco had me configure it a while back and it was working with the old circuit.  10.3.111.2 is the ip of the port on site 1 switch connected to one end of the circuit.  10.3.111.1 is the ip on the port on site 2 that is connected to the other site of the circuit.  Not sure where the confusion is...

Site 1:
interface FastEthernet1/0/2
 no switchport
 ip address 10.3.111.2 255.255.255.0

Site 2:
interface FastEthernet1/0/2
 no switchport
 ip address 10.3.111.1 255.255.255.0
0
 

Author Comment

by:vianceadmin
ID: 40479507
Cisco told me to configure the ports connected to the circuit with an IP and then put the local network in ospf as well as the interface connected to the circuit.  That's how I got the:

router ospf 1
 network 10.3.110.0 0.0.0.255 area 0.0.1.1
 network 10.3.111.0 0.0.0.255 area 0.0.1.1

router ospf 1
 network 10.3.101.0 0.0.0.255 area 0.0.1.1
 network 10.3.111.0 0.0.0.255 area 0.0.1.1
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40479508
Like I said, this isn't an OSPF problem.  You have a connectivity issue between site 1 and site 2.

What is the status of interface f1/0/2 on both switches?  "show ip int brief"
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 

Author Comment

by:vianceadmin
ID: 40479521
OSPF is how I'm connecting site 1 to site 2.  Site 1 cannot connect to site 2 without some type of routing...That's why I was using OSPF...

Site 1:  FastEthernet1/0/2      10.3.111.2      YES NVRAM  up                    up
Site 2:  FastEthernet1/0/2      10.3.111.1      YES manual up                    up
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40479536
Moving traffic between the to routing devices which are directly connected to the link does not require any routing protocol.

10.3.111.2 and 10.3.111.1 are on the same IP network.  No routing protocol is needed ping 10.3.111.2 from 10.3.111.1.  Just like no routing protocol is needed for your PC to ping its' default gateway.

The interfaces are showing as UP/UP so that's somewhat promising.  What do you see from a "show cdp neighbor"?

 What type of media is being used to connect these two devices together?  Fiber?  Copper?  Is is a provider service?
0
 

Author Comment

by:vianceadmin
ID: 40479540
I agree...10.3.111.2 and .1 are on the same network but they are on different switches/sites (again, this is how Cisco had me do it a while ago).  

When I do a sh cdp neighbor, I don't see anything connected to 1/0/2...

Using AT&T fiber between the two sites...They told me it is up and online.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40479577
I agree...10.3.111.2 and .1 are on the same network but they are on different switches/sites (again, this is how Cisco had me do it a while ago).  
It doesn't matter if they are 2 feet apart or 200 miles apart.  From an IP perspective, they are IP neighbors.  Which means that no routing protocol is needed to communicate.

When I do a sh cdp neighbor, I don't see anything connected to 1/0/2...
That tells you that you have no layer 2 connectivity.  And if there's no layer 2 connection, there won't be any layer 3 connection.

Using AT&T fiber between the two sites...They told me it is up and online.
Of course they do. That's their default response.  But it's not true.  :-)

I once had AT&T bring up a circuit to a site in Newport Beach, CA.  They said it was up and working fine. But not from my perspective. After a lot of back and forth, they discovered that the circuit was going to New Port Richey, FL.

That you have an UP/UP indication on your equipment tells you that you have a good link to the AT&T local equipment (CPE).  Which means the problem is between the site 1 CPE and the site 2 CPE.  Which means... AT&T.
0
 

Author Comment

by:vianceadmin
ID: 40479587
Roger that.  The fact that this worked in the past but stopped when we upgraded the circuit tells me that something is probably wrong with it on AT&T's side.  Appreciate the help...

So if you were trying to connect two sites over a private circuit, would you even use OSPF?  Or would you just setup static routes instead?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40479596
Glad to help.

 Routing protocols are called for when there is more than one link that can carry traffic, and you want failover capability.   Or when there are too many networks to create static routes for.
0
 

Author Comment

by:vianceadmin
ID: 40479616
Here was my total config on site 1 (down below).  Using VOIP so I have 771 vlan for voice and 586 vlan for data...

I see what you're saying about having the 10.3.111.1 and .2 on the same network so I just changed the IP on the interface for 1/0/2 on both site switches:

So now I have:

Site 1
10.3.120.1

Site 2
10.3.121.1

When I do a sh ip protocol, I get:

When I do a sh ip protocol, it shows:

  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 10.11.14.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    10.3.110.0 0.0.0.255 area 0
    10.3.120.0 0.0.0.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110

Shouldn't the router id be the port being used to do the routing (10.3.120.1)?  It's showing up as the ip for van 771 (voice)

Again, I know this could be AT&T but can you check the config so that if/when they get it working on their end, my end will be right as well?  


CLTCISCO01#sh run
Building configuration...

Current configuration : 10877 bytes
!
version 12.2
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname CLTCISCO01
!

!
no aaa new-model
clock timezone EST -5
clock summer-time CDT recurring 1 Sun Apr 2:00 4 Sun Oct 2:00
switch 1 provision ws-c3750-24p
system mtu routing 1500
vtp mode transparent
!
track 123 rtr 1 reachability
udld enable

ip subnet-zero
ip routing
!
ip multicast-routing distributed
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 586,771 priority 61440
!
vlan internal allocation policy ascending
!        
vlan 2,10,100,586,771
!
!
interface Port-channel1
 switchport access vlan 586
!
interface Port-channel2
 switchport access vlan 586
!
interface FastEthernet1/0/1
 description Link to ASA INSIDE interface
 switchport access vlan 586
!
interface FastEthernet1/0/2
 description Metro-E Link to CSI
 no switchport
 ip address 10.3.120.1 255.255.255.0
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust dscp
 auto qos voip trust
!
interface FastEthernet1/0/3
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet1/0/4
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet1/0/5
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet1/0/6
 description INSIDE2 Interface
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet1/0/7
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet1/0/8
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet1/0/9
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet1/0/10
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet1/0/11
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!        
interface FastEthernet1/0/12
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet1/0/13
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet1/0/14
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet1/0/15
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet1/0/16
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet1/0/17
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet1/0/18
 description Wireless Access Ports
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 586
 switchport trunk allowed vlan 2,586
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet1/0/19
 description Wireless Access Ports
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 586
 switchport trunk allowed vlan 2,586
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet1/0/20
 description Wireless Access Ports
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 586
 switchport trunk allowed vlan 2,586
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet1/0/21
 description Wireless Access Ports
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 586
 switchport trunk allowed vlan 2,586
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet1/0/22
 description Wireless Access Ports
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 586
 switchport trunk allowed vlan 2,586
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet1/0/23
 switchport access vlan 771
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 spanning-tree portfast
!
interface FastEthernet1/0/24
 switchport access vlan 586
 switchport trunk native vlan 586
 switchport voice vlan 771
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust cos
 auto qos voip trust
 no mdix auto
 no cdp enable
 spanning-tree portfast
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 586
 switchport trunk allowed vlan 2,586,771
 switchport mode trunk
 switchport nonegotiate
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust cos
 auto qos voip trust
!
interface GigabitEthernet1/0/2
 switchport access vlan 586
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 description Wireless_Guest_vLAN
 no ip address
!
interface Vlan586
 ip address 10.3.110.254 255.255.255.0
 no ip redirects
 ip pim dense-mode
 no ip mroute-cache
!
interface Vlan771
 ip address 10.11.14.1 255.255.255.0
 ip helper-address 10.3.110.21
 ip helper-address 10.3.110.20
 no ip redirects
 no ip mroute-cache
!
router ospf 1
 log-adjacency-changes
 network 10.3.110.0 0.0.0.255 area 0
 network 10.3.120.0 0.0.0.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.3.110.1
ip http server
!
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
ID: 40479631
On my phone now so I can't really review your config very well.  But I don't have to.  Your config on the first post was perfectly fine.  

Its not working because you don't have an operational link between your two sites.
0
 

Author Comment

by:vianceadmin
ID: 40483674
Appreciate the help...Turned out it was an issue with the ISP...
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now