Solved

windows 2012 verification of replica failed whilst deploy AD onto windows 2003 domain

Posted on 2014-12-03
12
1,780 Views
Last Modified: 2014-12-03
hi, I have a 2003 sbs network, I'm migrating to windows 2012 server.
So far I have increased the domain function level from 2000 to 2003 and done an adprep /forest on the 2012, which updated the 2003 sbs.
then added roles of AD domain services.
when I go to promote the 2012 and add domain controller to an existing domain, I get.

verification of replica failed. the forest functional level is windows 2000....

but under raise domain function it has windows server 2003.
There doesn't seem to be any event errors.

what am I doing wrong.
0
Comment
Question by:total123
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
12 Comments
 
LVL 4

Accepted Solution

by:
Zsolt Pribusz earned 500 total points
ID: 40479377
0
 

Author Comment

by:total123
ID: 40479402
easy when you know how, the forum I followed didn't mention that.
It's now progressed, but i'm getting

a domain controller running windows server 2008 or later could not be located in this domain. I do not have any 2008 servers.

thanks for your help so far
0
 
LVL 4

Expert Comment

by:Zsolt Pribusz
ID: 40479425
You ran  

Adprep /forestprep
Adprep /domainprep

commands from DVD?
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
LVL 4

Expert Comment

by:Zsolt Pribusz
ID: 40479444
Sorry, those aren't needed with 2012 anymore.

the 2012 server is joined to domain?
dns settings on server 2012 points to 2003sbs?
Oh, and one more thing, try promote 2012 server from GUI. Maybe you need only to type DSRM password.
0
 

Author Comment

by:total123
ID: 40479451
I ran Adprep /forestprep

not domain. just ran domainprep and still getting same error.
do I need to remove AD and reinstall role on 2012 ?
0
 
LVL 4

Expert Comment

by:Zsolt Pribusz
ID: 40479457
Ok, what about, the other comment?
0
 

Author Comment

by:total123
ID: 40479477
the server is on the domain and only has the sbs as the DNS server

I had just run forestprep before reading the last comment
0
 

Author Comment

by:total123
ID: 40479478
and domainprep
0
 

Author Comment

by:total123
ID: 40479498
managed to push replication through
0
 
LVL 4

Expert Comment

by:Zsolt Pribusz
ID: 40479500
If the error "A domain controller running Windows Server 2008, Windows Server 2008 R2, or Windows Server 2012 could not be located in this domain. To install ...." appears at the Active Directory Services Configuration Wizard, note that the "Next" button is disabled but if you set the password for "Type the Directory Services Restore Mode (DSRM) password", then the button is enabled and you should be fine continuing the wizard.
0
 

Author Closing Comment

by:total123
ID: 40479516
after raising forest as well, all worked fine, many thanks
0
 
LVL 4

Expert Comment

by:Zsolt Pribusz
ID: 40479520
welcome :)
0

Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Understanding the various editions available is vital when you decide to purchase Windows Server 2012. You need to have a basic understanding of the features and limitations in each edition in order to make a well-informed decision that best suits y…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question