Short DHCP leases not all showing on Server 2008. Too short?

I have a Wlan and that is designed for clients to connect, print, then move back to another Wlan.  I made the DHCP lease 20 minutes so many more clients could connect and print over an hour than I had addresses.  I had read that you could go as short as 1 minute without problems, except for the additional network traffic on that VLAN for DHCP requests, acks.....  

However, I'm seeing that DHCP scope as being full, or almost full, much of the time (491 total addresses) when looking at the statistics.  But when I look at the address leases, only about 150 or so show up.  That 150 usually is about the same as the current number of wireless clients I have on that VLAN.  When it shows a having no addresses left (in statistics) to hand out, it stops handing them out, even though the address leases don't show that many.

This just doesn't make sense to me.  All the other DHCP scopes look correct.  The number of used IP addresses in statistics is the same as the number of leases that are shown.

I've deleted and recreated the scope a few times, but the same thing always happens.

I'm wondering if the lease is too short, where the server won't reassign an address for a set amount of time, no matter how short you set your lease. But that doesn't correspond to what I've read.  

Any ideas?

To nip one idea in the bud, we have just the one DHCP server.  There isn't another server handing out the other addresses in a split scope scenario.  The addresses showing are #.#.#.21, #.#.#.22, #.#.#.30, #.#.#.42... when looking at the list of address leases.
Who is Participating?
JeffG2583Connect With a Mentor Commented:
I know in Server 2000-2003 there was a "grace period" for DHCP leases no longer in use. It sounds like this is what you're running into. Try adding the following registry key and restart the DHCP service on the server.

 DWORD value: LeaseExtension
 Value measure: minutes

I would set this to something like 10 minutes.
vivigattConnect With a Mentor Commented:
Maybe these articles will help you:
In particular, check the following registry keys (in addition to the LeaseExtension key that JeffG2583 mentioned):

DWORD value: DatabaseCleanupInterval
DWORD value: DynamicDNSQueueLength
davebuhlAuthor Commented:
Thanks.  I made a couple of changes and will see how that affects it on Monday.
davebuhlAuthor Commented:
I added LeaseExtension and modified the DatabaseCleanupInterval.

The combination of your two suggestions appears to be working perfectly.

Thanks for the help!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.